Bug #777 Accented characters cause truncation of text in a field of type text
Submitted: 2 Jul 2003 6:57 Modified: 1 Jun 2004 0:29
Reporter: Ronan O'Connor Email Updates:
Status: Closed Impact on me:
None 
Category:MySQLCC Severity:S2 (Serious)
Version:0.9.4 OS:Linux (Redhat 8)
Assigned to: Bugs System CPU Architecture:Any

[2 Jul 2003 6:57] Ronan O'Connor
Description:
Accented characters (eg é) causes truncation of text if entered via the field editor. 

How to repeat:
Open a query window for a table which has fields of type text. Add a new row (via the add new row button). Open the field editor window for the field of type text by double clicking that field. Enter the following text:
éé causes truncation
Hit the apply button. The field will now contain the text:
éé causes truncati

Suggested fix:
Stop the truncation.
[26 Aug 2003 2:56] Ronan O'Connor
Changed OS version
[27 Aug 2003 19:51] Jorge del Conde
I'm currently figuring out why this happens.  As of right now my best guess is this has something to do with either KDE or Qt.  The code that inserts/updates has been thoroughly checked and it works well in other OS'.  I will keep looking into this until I find a solution.

BTW, updating a BLOB field with a binary file uses the exact same updating code and this doesn't happen.
[28 Aug 2003 9:25] Jorge del Conde
After some testing and extensive debugging, I came to the conclusion mysqlcc is _NOT_ the source of this bug.  I will look into it deeper to figure out what the real cause of the bug is.  At a glance, I am almost certain mysqld is not the source of the problem either.
[21 Nov 2003 6:25] [ name withheld ]
This problem is quite annoying. Is there a KDE or MySQLCC patch to fix it ?
It should be quite easy. Thanks in advance.
[21 Nov 2003 6:49] Ronan O'Connor
Just to narrow it down slightly, I'm running GNOME (v.2.0) not KDE
[22 Nov 2003 1:35] [ name withheld ]
So it happens at least on GNOME/RH8 (for you) and KDE3/RH9 (for me)...

I don't understand why this bug doesn't get more attention.

Aren't GNOME and KDE the most common WM's, and aren't RedHat8/9 one of the most used linux distros ?
[10 Feb 2004 18:46] MySQL Verification Team
Tested 0.9.4 version on Suse 9.0 - KDE without truncation.
[10 May 2004 11:37] [ name withheld ]
Why close this bug ?  The problem is still here..  on a completely new system (and new laptop too):

Gentoo Linux 2004.0
mysqlcc 0.9.4
glibc 2.3.2
KDE 3.2.2

I'd be glad to provide any other details.
[10 May 2004 12:13] Ronan O'Connor
This is the second time you have closed a bug on me, by testing it with a different system. Even if you couldn't reproduce this bug, several people have already commented that they too have the same problem. And I can still reproduce the bug on both windows 2000 and Fedora core1 with Gnome 2.4 and mysqlcc 0.9.4 (and previously on Redhat 8 and 9 with mysqlcc 0.9.2 and 0.9.4).

In addition Jorge del Conde himself was able to reproduce this bug, if you read his previous comments you would see he was already looking for a solution.

If you need any further information on the bug I would be only too pleased to supply it.
[10 May 2004 19:00] Sergei Golubchik
Hmm, this bugs was fixed in 0.9.3.
Was the fix incomplete ?

Reopened for further testing...
(and changing "version" field to 0.9.4)
[24 May 2004 14:36] Ronan O'Connor
Further information: On a field of type TEXT, if the text is edited and an accented character is added the SQL in the History tab is incorrect. 
E.G.
The field currently contains:
This is some text.

Edit the field by double clicking, Field editor window pops up.
prefix the current text with 2 é characters and a space. In field editor window this should now look like this:
éé This is some text.

Apply the change. The field now contains the text:
éé This is some tex

Check the History tab, This has the following SQL statement:
UPDATE `test` SET `text`='éé this is some tex' WHERE `id`=1

It looks like the text from the field editor is not being read correctly.

By the way this is on a clean install of Fedora Core 2 (Gnome 2.6) and a clean install of MySQLCC 0.9.4 .
[25 May 2004 0:49] [ name withheld ]
It seems that all Unicode characters are assumed to take one byte. Unfortunately, when using UTF-8 this assumption is wrong for all characters above 0x80 (ie: non-ASCII).
[1 Jun 2004 0:29] Jorge del Conde
Hi!

MySQLCC will not be developed nor maintained anymore with the exception of Critical bugs.

In the near future we will release the substitute of MySQLCC called MySQL Query Browser.