Bug #77569 MySQL Workbench missing 64bit dependencies in 32bit systems
Submitted: 30 Jun 2015 20:55 Modified: 3 Aug 2015 13:43
Reporter: Marco Rios Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.3.4-1 OS:Fedora (fc21 32bit)
Assigned to: CPU Architecture:Any

[30 Jun 2015 20:55] Marco Rios
Description:
When trying to install MySQL Workbench on Fedora 21 32bit systems, there is a complaint of missing 64bit dependencies, although the package is intended to install on 32/64bit systems.

How to repeat:
Try to install rpm package of MySQL Workbench from 
http://dev.mysql.com/downloads/workbench/

Even when the respective 32bit packages aforementioned are already installed

Suggested fix:
Detect if the systems is 32 or 64 bit and select automatically respective dependencies
[1 Jul 2015 6:50] Mike Lischke
The package from the MySQL download page are 64bit only and only run on with 64bit dependencies. If you want a 32bit binary you have to compile it yourself.

Have you tried to run the 64bit WB with all necessary 64bit deps?
[31 Jul 2015 23:24] noName noSurname
On 32bit, you can install it by:
sudo apt-get install mysql-workbench
Now it install 6.0.8 version.
[3 Aug 2015 13:43] Miguel Solorzano
Please see comment:

[1 Jul 6:50] Mike Lischke

Thanks.