Bug #77541 Cmd-C will not always copy value from results grid
Submitted: 29 Jun 2015 13:35 Modified: 2 Jul 2015 7:37
Reporter: Alar Maerand Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.2.3 OS:Mac OS X (unknown)
Assigned to: CPU Architecture:Any
Tags: UI, WBBugReporter

[29 Jun 2015 13:35] Alar Maerand
Description:
Sometimes Cmd-C will copy the active cell value, sometimes not

How to repeat:
Just try to copy value from different query result cells on Mac. 
From menu Edit->Copy works always as expected, but shortcut does not
[29 Jun 2015 21:38] Miguel Solorzano
Thank you for the bug report. I couldn't repeat with 6.3.4 version.

MySQL Workbench Community (GPL) for Mac OS X version 6.3.4  revision 0 build 828 (32 bit)
Configuration Directory: /Users/miguel/Library/Application Support/MySQL/Workbench
Data Directory: /Applications/MySQLWorkbench.app/Contents/Resources
Cairo Version: 1.10.2
OS: OS X 10.10.x Yosemite
CPU: 4x Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz - 16.00GiB RAM
[2 Jul 2015 7:33] Alar Maerand
I also upgraded to 6.3.4 and I'm still able to reproduce it. Just select data from random table and click on/make active different Result Grid column and press Cmd-C first time the copy works but at some point you will hear this system error sound on Cmd-C and copy was not actually done.

Very annoying when you are working with shortcuts, because you never know if proper values gets copied.
[2 Jul 2015 7:37] Alar Maerand
In order repro it.. you just need to loose focus from the MySQLWorkbench window (activate other window with Cmd-Tab) and after that the Cmd-C is not fuctional anymore in  MySQLWorkbench window!