Bug #77378 The setup routines for the MySQL ODBC 5.3 ANSI Driver-Driver could not be found.
Submitted: 17 Jun 2015 5:27 Modified: 25 Jun 2015 10:57
Reporter: Padmahas B N Email Updates:
Status: Not a Bug Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:Connector/ODBC 5.3.4 OS:Microsoft Windows (Windows 8.1 64 bit)
Assigned to: CPU Architecture:Any
Tags: Registry entry not accessible under HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC

[17 Jun 2015 5:27] Padmahas B N
Description:
I'm using 64 bit windows 8.1. and installed 32 bit MySQL 5.6.25 server which installed Connector/ODBC 5.3.4 32 bit automatically and no error occured except python error message because I don't have python installed in my system.

But when I open ODBC Datasource administrator (32 bit), in the drivers tab there is entry for both MySQL ODBC 5.3 ANSI and Unicode driver but both of them doesn't contain any information such as version, company, file and date.

First error message:   While trying to add UserDSN using ANSI or Unicode, the first message shown is, "The setup routines for the MySQL ODBC 5.3 ANSI Driver ODBC driver could not be found. Please reinstall the driver".

Second Error mesaage: When press ok another error message shows "Errors found: Component not found in the registry".

Following the second error message, I opened regedit in "run",
Under HKEY_LOCAL_MACHINE -> SOFTWARE -> Wow6432Node -> ODBC -> ODBCINST.INI,
The entry for both MySQL ODBC 5.3 ANSI Driver and Unicode driver is found but I cannot open, modify or delete the entry.

It says "MySQL ODBC 5.3 ANSI Driver cannot be opened. An error is preventing this key from being opened. Details: Access is denied."

This is definitely the issue with registry entry. When I installed 64 bit ODBC, I could access those entries under HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\MySQL ODBC 5.3 ANSI Driver.

How to repeat:
To repeat the error, after installing 32 bit version in the 64 bit version windows 8.1, try to create UserDSN.

I tried creating new key in the registry with different name and 32 bit related paths, but it doesn't show in the ODBC Datasource Administrator.
[17 Jun 2015 5:30] Padmahas B N
Tags edited
[17 Jun 2015 5:35] Padmahas B N
Screen shots of the errors

Attachment: ODBC error1.jpg (image/jpeg, text), 25.26 KiB.

[17 Jun 2015 5:36] Padmahas B N
Screenshot of the error 2

Attachment: ODBC error2.jpg (image/jpeg, text), 19.44 KiB.

[17 Jun 2015 5:36] Padmahas B N
Screenshot of the MySQL entry without other information

Attachment: ODBC 32bit.jpg (image/jpeg, text), 96.79 KiB.

[17 Jun 2015 6:08] Padmahas B N
Registry error. Which I cannot change the permission of that key

Attachment: ODBC regedit.jpg (image/jpeg, text), 21.61 KiB.

[17 Jun 2015 7:21] Chiranjeevi Battula
Hello Padmahas,

Thank you for the bug report.
I tried to reproduce the issue at my end using Windows 8.1 and MySQL ODBC 5.3.4 32 bit but couldn't trace out any issue in create user DSN.
Please use the path to create user DNS and Windows has two versions of ODBC administrator: a 32-bit one (\Windows\Syswow64\odbcad32.exe) and 64-bit one (\Windows\System32\odbcad32.exe)

Thanks,
Chiranjeevi.
[17 Jun 2015 7:23] Chiranjeevi Battula
screenshot.

Attachment: 77378.PNG (image/png, text), 117.29 KiB.

[17 Jun 2015 9:27] Padmahas B N
Hello Chiranjeevi Battula, yes I tried the ODBC from the path, (\Windows\Syswow64\odbcad32.exe) as you suggested, but still the problem is same.

And I forgot to mention that, whether I install or uninstall the MySQL Connector/ODBC 32 bit, an entry for both ANSI and Unicode shows without any information like version, company, file and date under the drivers tab in ODBC DataSource Administrator (32bit). I have uploaded the screenshot for that here (http://bugs.mysql.com/file.php?id=22847&bug_id=77378). But in case of 64 bit ODBC Connector when I uninstall the connector, the entry for both ANSI and Unicode disappears.

And what about the second error message? The registry key under HKEY_LOCAL_MACHINE -> SOFTWARE -> Wow6432Node -> ODBC -> ODBCINST.INI ?

Can you access or modify it?
Please suggest me how can I completely remove that registry key without any permission issue, because I can't change the permission.
[17 Jun 2015 10:14] Chiranjeevi Battula
Hello Padmahas,

Thank you for your feedback.
Same bug was reported in (http://bugs.mysql.com/bug.php?id=75926)  regarding version details.
Please download and reinstall the 32/64 bit ODBC drivers from here https://dev.mysql.com/downloads/connector/odbc/

Thanks,
Chiranjeevi.
[22 Jun 2015 12:35] Padmahas B N
Hello Chiranjeevi Battula,

I downloaded the ODBC driver from the link suggested by you above. But it didn't change the situation, however I found the way.

I don't know whether it is the problem only with me or others too who try to install 32 bit version on 64 bit machine and Operating System.

SOLUTION:

STEP 1:-

When it is not possible to modify or delete the registry key under "HKEY_LOCAL_MACHINE -> SOFTWARE -> Wow6432Node -> ODBC -> ODBCINST.INI",
Take the ownership of the key by right clicking on the "ODBC" (not on the MySQL ODBC key but the previous directory in which MySQL ODBC exists), choose "Permissions -> Advanced". There the current owner is showed as SYSTEM (Usually) on the first line of the dialog box itself. Click "change" type your user name and click "check names". When your username is listed without error click OK -> OK -> OK.

STEP 2:-

No right click on the MySQL ODBC 5.3 ANSI Driver -> Choose Permissions -> Select Add -> type your username and click "check names" -> Click OK if your username is listed without error -> OK.
Do the same for Unicode driver

For me in this stage, all four sub keys of MySQL ODBC 5.3 ANSI and Unicode such as Default, Driver, Setup, and UsageCount were automatically set and in  Control panel -> Administrative tools -> ODBC Datasource Administrator 32 bit -> Driver tab, I could see info such as version, company, file and date which were showing empty previously and also I could add the User DSN successfully.

Thank you for your suggestion and support.
[25 Jun 2015 10:57] Chiranjeevi Battula
Hello Padmahas,

Thank you for your feedback and confirming permission issue.

Thanks,
Chiranjeevi.
[6 Mar 2018 8:47] Prashant Sharma
Thanks. Installing MySQL ODBC connector 32 bit solved my problem.