Bug #7736 Can't edit records with 1.1.4/1.1.5
Submitted: 7 Jan 2005 18:48 Modified: 16 Feb 2005 14:32
Reporter: Christopher Gonzalez Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Query Browser Severity:S3 (Non-critical)
Version:1.1.5 OS:Microsoft Windows (Windows Server 2003)
Assigned to: Mike Lischke CPU Architecture:Any

[7 Jan 2005 18:48] Christopher Gonzalez
Description:
I recently upgraded to 1.1.4 (few days ago) and 1.1.5 (today, 1/07/05).  For some reason, I can't edit ANY records from any of my schemas.  I used to be able to edit most of them with a few exceptions, but now it's become a nuisance.
I had been using Query Browser since 1.0.8 beta, and hadn't run into this problem since I installed 1.1.4.

Has anyone else experienced this problem?  And how would I go about fixing it?

Christopher Gonzalez

How to repeat:
Upgrade to 1.1.4/1.1.5
[7 Jan 2005 19:58] MySQL Verification Team
I was able to repeat with a table with just one column char(34)
then noticed that the edit button is grayed, when I added one more
column int primary key auto_increment the button edit was
enabled.

Thank you for the bug report.
[7 Jan 2005 20:19] Christopher Gonzalez
Hmmm, I tried uninstalling and reinstalling both Query Browser 1.1.5 and Administrator 1.0.18 to see if a fresh install would solve any problems.  Still, I can't seem to edit any records, and now I'm getting a connection error when I try to view a schema other than the default.

The connection error reads as follows:

Access violation at address 00345546 in module 'libmysqlx.dll'. Read of address 0000028C

Not sure how to further explain.
[10 Jan 2005 16:27] Christopher Gonzalez
I think I just found out what my problem was, although this could lead to a new bug...

I installed QB on the database server itself, and was immediately able to view schemas and edit the records.  I'm guessing that you cannot edit records from a remote server/computer, as that was my problem.

Should this be listed as a different bug?

Chris
[11 Jan 2005 10:24] Lars Annerstedt
I can edit schemas for 'world' database and 'mysql' database but not my own created databases (converted from MS SQL), although I can edit them programatically from within VB6.
[11 Jan 2005 14:52] Victor Vagin
Can you show us the result of
show create table <table_name>;
for the table you can't edit?
[11 Jan 2005 15:33] Christopher Gonzalez
I get an empty set in the ResultSet window.  Toward the bottom, it reads "The query cannot be executed."  There's also a message below that with a red exclamation point, reading "Lost connection to MySQL server during query", error number 2013.

It finally decided to connect to my development DB server (like 5 mins ago, not sure what I did), but it's the production one that needs to be working, which is the one throwing these errors.
[17 Jan 2005 10:16] Lars Annerstedt
This is an example of a 'create table' where the table can't be edited

CREATE TABLE `info` (
  `InfoText` text
) ENGINE=InnoDB DEFAULT CHARSET=latin1
[23 Jan 2005 10:05] Lars Annerstedt
I've noticed that if a table has a primary key it is possible to edit.
If this is by design the QB is useless for me!
[16 Feb 2005 14:32] Mike Lischke
Unfortunately, it is not possible to edit data for tables without a primary key. It is needed to find a reliable association between the data in QB and that in the schema.