Bug #77335 Unable to import JSON using the Table Data Import Wizard
Submitted: 12 Jun 2015 12:56 Modified: 16 Oct 2015 3:12
Reporter: John Smith Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.3.3.0 build 592, 6.3.4 OS:Microsoft Windows (Windows7)
Assigned to: CPU Architecture:Any

[12 Jun 2015 12:56] John Smith
Description:
When importing via Wizard in the Configure Import Settings section "Can't analyze file, please try to change encoding type...". Both table and data are utf8 with the data all numeric with no metacharacters.

How to repeat:
Follow instructions using Table Data Import Wizard. Cannot get beyond Configure Import Settings section.
[15 Jun 2015 5:51] Umesh Shastry
Hello John Smith,

Thank you for the report.
Observed this with WB 6.3.4.0(build 772) on Win7.

Thanks,
Umesh
[15 Jun 2015 5:53] Umesh Shastry
// How to repeat
// Create schema, populate data

use test;
drop table if exists employees;
create table employees(id int, firstname varchar(100),lastname varchar(100),key(id));
insert into employees values(1,"Mysql","my'SQL");

-- SELECT table data, export as .json

SELECT * FROM test.employees;

-- Truncate table, use Table Data import wizard option to import just exported.json file
[15 Jun 2015 5:54] Umesh Shastry
.json file

Attachment: employee.json (application/octet-stream, text), 72 bytes.

[15 Jun 2015 5:54] Umesh Shastry
Screenshot..

Attachment: 77335.png (image/png, text), 89.92 KiB.

[13 Jul 2015 11:30] Marcin Szalowicz
bug #77270 is a duplicate of this one.
[16 Oct 2015 3:12] Philip Olson
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 6.3.5 release, and here's the changelog entry:

When importing JSON,
the Table Data Import wizard would fail at the Configure Import Settings
step, and emit "Can't analyze file, please try to change encoding
type...".

Thank you for the bug report.
[25 Feb 2016 17:54] Mike Davis
I am still encountering this bug, using MySQL Workbench 6.3.5 Build 201 CE (64-bit) on Windows 7 Enterprise SP 1.

I am unable to do a data import using JSON.
[1 Jun 2016 19:54] Tom Ranalli
Having the same problem with Mac OS version 6.3.6.
[12 Jun 2016 21:10] Rayvn Manuel
I am also experiencing this issue - windows 10 - workbench 6.3.6 Build 511 CE (64 bit)