Bug #77334 Can't refresh connections in excel after opening the document
Submitted: 12 Jun 2015 12:38 Modified: 25 Jun 2015 10:10
Reporter: Benjamin Hänisch Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL for Windows: MySQL for Excel Severity:S2 (Serious)
Version:1.3.4 OS:Microsoft Windows (7 Professional SP1)
Assigned to: CPU Architecture:Any
Tags: conncections, disappear, lost

[12 Jun 2015 12:38] Benjamin Hänisch
Description:
I use MYSQL for Excel to connect to our database and retrieve 5 tables. I set up all necessary connections and all data is successfully imported. When I safe the file excel asks if I want to safe changes made so SOLVER.xlsm (which I didn't open or use) and even after responding yes and also saving the file (as a .xlsm) with the connections itself, when reopening the file all imported data is gone and no connections exist. 

This outcome however is not always the same. Sometimes the data is still there and the connections too, but when trying to refresh all data I get "Ausnahme von HRESULT: 0x800A03EC" for each table. 

How to repeat:
Set up connections to the db.

safe file

reopen said file

either all imported data and connections are gone or data and connections are still present but can't be updated.
[12 Jun 2015 12:52] MySQL Verification Team
Looks like duplicate of http://bugs.mysql.com/bug.php?id=76687 (same error message). Please check. Thanks.
[12 Jun 2015 12:53] Benjamin Hänisch
in the latter case it appears to be, but I'm also not able to refresh table individualla
[25 Jun 2015 9:17] Benjamin Hänisch
I don't know why, or what changed, but now the refreshing works without any problems. I'm still using the same file I used before. 

So I guess you can close this ticket.
[25 Jun 2015 10:10] MySQL Verification Team
Thank you for the feedback.