Bug #7729 value for column XXX exceeds column's (but value < column field length)
Submitted: 7 Jan 2005 12:31 Modified: 30 May 2013 12:33
Reporter: Daniel Schröder Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:3.23.58 & 4.01.4 OS:Microsoft Windows (Windows2k Server)
Assigned to: CPU Architecture:Any

[7 Jan 2005 12:31] Daniel Schröder
Description:
my test case:
i want to connect a oracle db (ver. 9.2.0.4 / win2K server) with an mysql db (3.23.58 & 4.01.4 / linux) via (HS) MyODBC Connector (MySQL ODBC Driver Win 3.51.10). from oracle i use a database link to work with the MySQL DB.

select statements still working but i have some problems with insert and updates, especially with string inserts.

i have mysql tables (InnoDB & myIsam both if've tried) with varchar fields of 255 chars.
now i tried insert a record by the following statement:
"INSERT INTO TABLE_TEST@MYSQLDB (TEST) VALUES ('this is a test');"

and i get this message vom oracle:
INSERT INTO TABLE_TEST@MYSQLDB (TEST) VALUES ('this is a test');
ORA-28500: Verbindung von ORACLE zu Fremdsystem gab diese Nachricht zurück:
[Generic Connectivity Using ODBC][A0C9] Value for column TEST exceeds column's 
ORA-02063: vorangestelltes 2 lines von MYSQLDB

that is very curious, because in some columns i can insert 125, 34, 6, 1 an 0 chars, but evere column is created with 255 

How to repeat:
- Server: Win2K Server/Oracle (ver. 9.2.0.4)
- >Oracle Datebase Link<
- >HS ODBC Connection<
- Server: Linux/MySQL (both if've tried ver. 3.23.58 & 4.01.4)

Create Table Script:
CREATE TABLE `RADCHECK` (
  `ID` INT(11) unsigned NOT NULL auto_increment,
  `USERNAME` VARCHAR(64) NOT NULL DEFAULT '',
  `ATTRIBUTE` VARCHAR(32) NOT NULL DEFAULT '',
  `OP` CHAR(2) NOT NULL DEFAULT '==',
  `VALUE` VARCHAR(255) NOT NULL DEFAULT '',
  PRIMARY KEY  (`ID`),
  KEY `USERNAME` (`USERNAME`(32))
) TYPE=MyISAM; 
/* ) TYPE=InnoDB; */

Upadte Script:
UPDATE RADCHECK SET VALUE = 'AEBDNMTIEOMSDJJIELLDJSDA' WHERE ID = 5;
[5 Feb 2005 16:37] Jorge del Conde
A new version of MyODBC is about to be released that has many bug fixes.  Can you try to reproduce this behaviour with this version (3.51.10-3) and tell me if it fails or not ?
[6 Mar 2005 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[30 May 2013 12:33] Bogdan Degtyariov
Thank you for your bug report. This issue has already been fixed in the release version of that product, which you can download at

  http://www.mysql.com/downloads/