Bug #77165 Hitting the bug
Submitted: 27 May 2015 6:53 Modified: 2 Jun 2015 20:31
Reporter: Anirban Chakraborty Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.1.22 OS:Other (Linux)
Assigned to: CPU Architecture:Any

[27 May 2015 6:53] Anirban Chakraborty
Description:
After node restart got this:
150527  0:45:23 - mysqld got signal 6;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=8388600
read_buffer_size=131072
max_used_connections=1
max_threads=151
threads_connected=0
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 338150 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
frame pointer is NULL, did you compile with
-fomit-frame-pointer? Aborting backtrace!
The manual page at http://www.mysql.com/doc/en/Crashing.html contains
information that should help you find out what is causing the crash.
150527 00:45:23 mysqld_safe Number of processes running now: 0
150527 00:45:23 mysqld_safe mysqld restarted
150527  0:45:23  InnoDB: Started; log sequence number 0 46449
150527  0:45:27 [Warning] NDB: server id set to zero will cause any other mysqld with bin log to log with wrong server id
150527  0:45:27 [Note] Starting MySQL Cluster Binlog Thread
150527  0:45:27 [Note] Event Scheduler: Loaded 0 events
150527  0:45:27 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.22-rc-community'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  MySQL Community Edition (GPL)
INVALID SUB_GCP_COMPLETE_REP
gci: 103201796
sender: 1010002
count: 2
bucket count: 1
nodes: 3
150527  0:46:11 - mysqld got signal 6;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=8388600
read_buffer_size=131072
max_used_connections=5
max_threads=151
threads_connected=4
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 338150 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
frame pointer is NULL, did you compile with
-fomit-frame-pointer? Aborting backtrace!
The manual page at http://www.mysql.com/doc/en/Crashing.html contains
information that should help you find out what is causing the crash.
150527 00:46:11 mysqld_safe Number of processes running now: 0
150527 00:46:11 mysqld_safe mysqld restarted
150527  0:46:11  InnoDB: Started; log sequence number 0 46449
150527  0:46:14 [Warning] NDB: server id set to zero will cause any other mysqld with bin log to log with wrong server id
150527  0:46:14 [Note] Starting MySQL Cluster Binlog Thread
150527  0:46:14 [Note] Event Scheduler: Loaded 0 events
150527  0:46:14 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.22-rc-community'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  MySQL Community Edition (GPL)
INVALID SUB_GCP_COMPLETE_REP
gci: 103201813
sender: 1010002
count: 2
bucket count: 1
nodes: 3
150527  0:46:48 - mysqld got signal 6;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=8388600
read_buffer_size=131072
max_used_connections=4
max_threads=151
threads_connected=3
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 338150 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
frame pointer is NULL, did you compile with
-fomit-frame-pointer? Aborting backtrace!
The manual page at http://www.mysql.com/doc/en/Crashing.html contains
information that should help you find out what is causing the crash.
150527 00:46:48 mysqld_safe Number of processes running now: 0
150527 00:46:48 mysqld_safe mysqld restarted
150527  0:46:48  InnoDB: Started; log sequence number 0 46449
150527  0:46:52 [Warning] NDB: server id set to zero will cause any other mysqld with bin log to log with wrong server id
150527  0:46:52 [Note] Starting MySQL Cluster Binlog Thread
150527  0:46:52 [Note] Event Scheduler: Loaded 0 events
150527  0:46:52 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.22-rc-community'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  MySQL Community Edition (GPL)

How to repeat:
DO not know how it can be repeated.
[27 May 2015 7:26] Shane Bester
Anirban, 5.1.22 is too old to file bugs against now.
I'd recommend you try 5.1.73, 5.5.43, or 5.6.24 and see if same issue persists.

Thousands of crashing bugs are fixed since 5.1.22:
http://dev.mysql.com/doc/relnotes/mysql/5.1/en/
[2 Jun 2015 17:42] Anirban Chakraborty
Just restarted management node and data nodes. And it got resolved.
[2 Jun 2015 20:31] Miguel Solorzano
Closing according last comment and very older version reported.