Bug #7702 Cannot connect to service following new install
Submitted: 6 Jan 2005 13:32 Modified: 6 Jan 2005 23:24
Reporter: Iain Hosking Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:4.1.8 (and 4.1.7) OS:Microsoft Windows (Windows XP SP2)
Assigned to: CPU Architecture:Any

[6 Jan 2005 13:32] Iain Hosking
Description:
At the end of a new install of 4.1.8 (and previously 4.1.7) MySQL cannot connect to the service to update security settings. Following this, no client can connect (MySQL Administrator, MySQL Query Browser, mysql command-line utility). MySQL system tray monitor shows the service running on port 3306, and this is confirmed in the list of Windows services.

Previously used 4.0.15, 4.1.4 and 4.1.5 on the same PC & o/s; currently using 4.1.7 on W2K and Linux on other systems without problems.

Have tried: uninstalling & reinstalling; removing all old MySQL versions (except 4.0); turning off XP firewall; deleting MySQL-related registry entries; rebooting.

All installation choices were defaults. Nothing unusual about the PC or o/s.

Hoping for a quick resolution as of course cannot now use MySQL at all on this PC.

Tried to post on forum (in Installs) but my post did not appear.

How to repeat:
It's perfectly repeatable here. I don't have another XP machine to try it on.

Suggested fix:
I can only see going back to an older version, which is highly unsatisfactory. 

Note that we are using 4.1.7 commercially (on Linux).
[6 Jan 2005 14:19] Victoria Reznichenko
Hi,

What error do you receive when you try to connect?
[6 Jan 2005 23:24] Michael G. Zinner
When doing a de-install, please make sure you MANUALLY remove the MySQL data directory. This is not removed my the de-installer automatically.

Therefore you might have an old password from your last installation still stored in the user table in the data-directory. So you cannot connect using a new one.

We have added a special warning to the Configuration Wizard explaining the issue.

Please try with 4.1.9 which will include the fix.

I close this bug for now. Please re-open it when you still have problems.
[7 Jan 2005 0:16] Iain Hosking
Victoria - With 4.1.8 the error is:

"The security settings could not be applied.
Error number 2017.
Can't open named pipe to host:. pipe:mysql(2)"

With 4.1.7 the error is

"MySQL Error Number 1045
Access denied for user'root'@'localhost' (using password: YES)"

I will download 4.1.9 and try removing the old MySQL directory before installation as per Michael's suggestion.

Thanks
Iain
[7 Jan 2005 14:02] Iain Hosking
Michael G. Zinner's response contained the solution - manually remove the data directory from the previous MySQL installation.

Thanks for that!

Iain