Bug #76682 MySQL Cluster Auto-installer don't work on windows.
Submitted: 13 Apr 2015 21:18 Modified: 14 Apr 2015 9:04
Reporter: Meiji Kimura Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Cluster: Configurator Severity:S2 (Serious)
Version: OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[13 Apr 2015 21:18] Meiji Kimura
Description:
MySQL Cluster Auto-installer is supported on Windows platform.

http://dev.mysql.com/doc/refman/5.6/en/mysql-cluster-install-auto.html

I tried to setup 'MySQL Cluster' using Auto-installer, On linux always work, but On Windows always fail when Resource info Fetching...

1.Define cluster: Default settings -> Next
2.Define hosts: Host 127.0.0.1 Resource info -> Fetching... -> Failed

I think there is wrong code on python. I tried to use setup.bat and bin/ndb_setup.py with Active Python. All trial failed.

Try to do in Windows Vista, Win7, WHS2011(Windows Server 2008/R2) with Admin/non-admin, all case are failed.

How to repeat:
1. Download Cluster's tar file on windows and extract all files.
   (e.g. mysql-cluster-gpl-7.3.2-win64.zip)
2. Run setup.bat
3. Create New MySQL Cluster
4. Push 'Next' on Define Cluster, Default settings as belows.

Cluster name: MyCluster
Host list: 127.0.0.1
Application Area: simple testing
Write load: medium

5.On Define hosts page, script try to fetch Resource info on 127.0.0.1, but failed.

Suggested fix:
It should work on windows. I tested also localhost, ::1 instead of 127.0.0.1, and 7.3.2, 7.3.8, 7.4.5.
[14 Apr 2015 9:04] Umesh Shastry
Hello Meiji-San,

Thank you for the report.
I cannot reproduce reported issue i.e "Define hosts" steps always succeeds for "New MySQL Cluster" at my end with both mysql-cluster-gpl-7.3.8-winx64.zip/mysql-cluster-gpl-7.4.5-winx64.zip on Win7(eng locale). If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.

Regards,
Umesh