Bug #76669 Applying alter table hangs MySQL Workbench
Submitted: 12 Apr 2015 22:04 Modified: 29 Feb 2016 14:36
Reporter: Ferenc Szidarovszky Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:6.2.4/6.2.5 OS:Mac OS X (10.10.2)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[12 Apr 2015 22:04] Ferenc Szidarovszky
Description:
When applying table changes, after the change happens, the modal window doesn't change. Can't close, can't abort.

How to repeat:
Have a table's columns opened in the Schemas view and click on the table name to have the columns show below too.
Then Choose alter table in the context menu on the table name, add a field then apply the changes. After the change happening, the modal window doesn't change. Can't close, can't abort.

It seems that if the table is not selected in schema view the problem doesn't happen.
[13 Apr 2015 11:36] MySQL Verification Team
I couldn't repeat with 6.2.5 version. Please try it. Thanks.
[13 Apr 2015 13:47] Ferenc Szidarovszky
OK, downloading it just now. However:
1. Check for updates returned the software is up to date.
2. When going to the MySQL Workbench site through the menu, the download button didn't work (had no visible effect). So I had to redo the process in the browser.
Should I submit a ticket each for these problems too?
[13 Apr 2015 13:51] Ferenc Szidarovszky
I was able to reproduce the problem right on the first try with 6.2.5
[13 Apr 2015 23:34] MySQL Verification Team
Call Stack

Attachment: call_stack_bug76669.txt (text/plain), 79.05 KiB.

[13 Apr 2015 23:36] MySQL Verification Team
Thank you for the feedback. I got a crash too.
[4 May 2015 16:12] Marios Savva
I have the same problem. Sometimes it doesn't happen right away on the first change, but it definitely happens on a 2nd change.
[4 Jan 2016 13:05] Marcelo Zucareli
When changing any remote data, workbench crashes. I'm using 6.2.5 version.
[29 Jan 2016 14:36] Marcin Szalowicz
Hello Ferenc, Marlos, Marcelo
I've tried to repeat this with 6.3.6 on Yosemite without success. 
Please upgrade to 6.3.6 and leave feedback if it's ok.
[1 Mar 2016 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".