Bug #76662 Cannot edit or view user permissions in MYSQL Workbench
Submitted: 10 Apr 2015 20:57 Modified: 16 Nov 2015 14:38
Reporter: not public Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.2.3 OS:Linux (Microsoft Windows 8.1 Pro)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[10 Apr 2015 20:57] not public
Description:
I get an instant error

[Window Title]
MySQL Workbench

[Main Instruction]
Error

[Content]
Unhandled exception: DbMySQLQuery.resultFieldStringValueByName(): MySQL_ResultSet::isNull: invalid value of 'columnLabel'

Debian 7.8 x64

How to repeat:
Install MySQL server and use mysql workbench to view usrs

mysql  Ver 14.14 Distrib 5.7.6-m16, for Linux (x86_64) using  EditLine wrapper
[13 Apr 2015 23:40] Miguel Solorzano
Please try version 6.2.5 and development release 6.3.2 rc. Thanks.
[22 Apr 2015 20:36] Leigh Johnson
Workbench 6.2.5.0 build 397 (64 bit) is generating the same error on both Windows Server 2012 R2 (local) and Windows 8.1 Professional (remote):

Error

Unhandled exception:
DbMySQLQuery.resultFiledStringValueByName():
MySQL_ResultSet::isNull: invalid calue of 'columnLabel'
[23 Apr 2015 2:44] Duc Nguyen
Same error for Windows 7 on version 6.2.5 64bit.
[29 Apr 2015 5:47] Umesh Shastry
Thank you for the feedback.
I'm able to repeat this issue on Win7 with WB 6.2.5 but not seeing this issue with latest GA 6.3.3 builds on Win7, Ubuntu 15.04. Please could you check with latest GA build 6.3.3?

Thanks,
Umesh
[29 Apr 2015 5:50] Umesh Shastry
Screenshot.. 6.2.5

Attachment: 76662_6_2_5.png (image/png, text), 81.54 KiB.

[29 Apr 2015 5:52] Umesh Shastry
Screenshot.. 6.3.3

Attachment: 76662_6_3_3.png (image/png, text), 52.40 KiB.

[30 May 2015 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[16 Nov 2015 14:31] Milos Baran
I'm having identical issue

"Unhandled exception: DbMySQLQuery.resultFieldStringValueByName(): MySQL_ResultSet::isNull: invalid value of 'columnLabel'"

MySQL 5.7.9 (Windows)

MySQL Workbench 6.2.4 (Mac)

I managed to add new user but I'm unable to view/edit properties for existing one.

Milos
[16 Nov 2015 14:33] Milos Baran
Latest version 6.3.5 seems to be fine
[16 Nov 2015 14:38] Miguel Solorzano
Thank you for the feedback.
[2 Jun 2016 19:04] Marc Hoffman
I'm using version 6.36 of MySQL Workbench, and I'm getting the same error.
[2 Jun 2016 19:36] Marc Hoffman
I downgraded MySQL Workbench to version 6.3.2, and things are fine now.
[5 Jan 2017 8:56] Tomer Noy
I have Mac (macOS sierra) with mySQL WorkBench 6.1.7 with MYSQL server 5.7.17 with the same problem: "Unhandled exception: DbMySQLQuery.resultFieldStringValueByName(): MySQL_ResultSet::isNull: invalid value of 'columnLabel'"

anyone help?
[12 Jan 2017 18:06] Roy Levien
Same error on 

macOS 10.12.2 (16C67)
mysql  Ver 14.14 Distrib 5.7.17
MySQL Workebch 6.2.4.12437