Bug #76608 MySQL Web Installer 5.6.24 / 1.4 crashes on startup
Submitted: 7 Apr 2015 10:26 Modified: 3 Oct 2017 16:53
Reporter: Yngve Svendsen Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:5.6.24 OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any

[7 Apr 2015 10:26] Yngve Svendsen
Description:
Downloaded MySQL Web Installer 5.6.24 from dev.mysql.com. Ran it. Splash screen appeared ("MySQL Installer 1.4"). Got prompted to update the list of available products. Answered yes to that. Promptly got a "MySQL Installer has stopped working" with the below problem details. The Installer still proceeded (or did it restart automatically?) and ran OK

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	MySQLInstaller.exe
  Application Version:	1.4.5.0
  Application Timestamp:	5517650c
  Fault Module Name:	KERNELBASE.dll
  Fault Module Version:	6.1.7601.18409
  Fault Module Timestamp:	5315a05a
  Exception Code:	c0020001
  Exception Offset:	000000000000940d
  OS Version:	6.1.7601.2.1.0.256.1
  Locale ID:	1044
  Additional Information 1:	665a
  Additional Information 2:	665a92c35979ab761f05d35715ddb8c9
  Additional Information 3:	6d09
  Additional Information 4:	6d09c27daae96e77b9e156f12addff78

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt

How to repeat:
TBD
[7 Apr 2015 10:33] Yngve Svendsen
Reran the Installer. Uninstalled all MySQL products, including the Installer itself. Rebooted. Reran the installer. Exactly same crash. Seems the product list download bar gets to something like 20% before the crash message appears. It does proceed after the crash and appears to work normally, though.
[7 Apr 2015 10:52] Yngve Svendsen
This does *not* happen with the full installer.
[7 Apr 2015 11:37] Umesh Shastry
Hello Yngve Svendsen,

Thank you for the report.
Observed similar behavior on Win7 with mysql-installer-web-community-5.6.24.0.msi.

Thanks,
Umesh
[7 Apr 2015 11:38] Umesh Shastry
// This is easy to hit(just uninstall previously installed installer and try to install 5.6.24 web install.

Faulting application name: MySQLInstaller.exe, version: 1.4.5.0, time stamp: 0x5517650c
Faulting module name: KERNELBASE.dll, version: 6.1.7601.18409, time stamp: 0x5315a05a
Exception code: 0xc0020001
Fault offset: 0x000000000000940d
Faulting process id: 0x220c
Faulting application start time: 0x01d071240f12e599
Faulting application path: C:\Program Files (x86)\MySQL\MySQL Installer for Windows\MySQLInstaller.exe
Faulting module path: C:\windows\system32\KERNELBASE.dll
Report Id: 577de996-dd17-11e4-aff1-bc305bc8d894
[16 Apr 2015 11:50] Yngve Svendsen
This was completely reproducible (uninstall, reboot, reinstall, crash) on my system until I:

* Uninstalled the Installer and all MySQL products
* Rebooted
* Used regedit to delete all keys that I suspected could be leftovers either from the latest Installer or older incarnations that I have historically used. In particular, these keys looked like ones that maybe shouldn't be there after an uninstall:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Tracing\MySQLInstaller_RASAPI32
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Tracing\MySQLInstaller_RASMANCS
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Tracing\MySQLInstallerUpdater_RASAPI32
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Tracing\MySQLInstallerUpdater_RASMANCS
* Rebooted
* Reinstalled without crash

I also tried various combinations of installing the DOA 5.6.23-0 installer and upgrading that using the 5.6.24 installer, and I was unable to reproduce the crash.

Bottom line: multiple historical installs and reinstalls of different Installer versions seems to have left items in my Registry that caused the issues I was seeing.
[24 Aug 2015 6:02] Abraham Guyt
I've got a similar bug with the web installer version 5.6.26.0 (installer version 1.4.10) - trying to launch the app results in the error "Internal error (object reference not set to instance)".

Fault bucket 120301723704, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: MySQLInstaller.exe
P2: 1.4.10.0
P3: 55ce1af5
P4: KERNELBASE.dll
P5: 6.3.9600.17415
P6: 54505737
P7: c000041d
P8: 0000000000008b9c
P9: 
P10:
[6 Sep 2015 11:36] Rick Novak
Hi,
I have similar behaviour as Abraham described.
Having the 5.6.26 products installed on Vista Business I have tried to check the updates using the installer 1.4.8. It has requested self update first and after this was done the start of updated installer fails. No installing job with products is possible at all.
[3 Oct 2017 16:53] Javier TreviƱo
Wasn't able to repeat this bug with latest installer version.