Bug #76489 missing partitioning type COLUMNS
Submitted: 26 Mar 2015 2:34 Modified: 28 Mar 2018 17:40
Reporter: Hailin Hu Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:6.2.5,6.3.3 OS:Mac OS X
Assigned to: CPU Architecture:Any

[26 Mar 2015 2:34] Hailin Hu
Description:
There is no partitioning type COLUMNS in "Partition by" of "Partitioning" tab.

If I use "Synchronize Model" to "Update Model" from an existed table which created with partitioning type COLUMNS, SQL Export will generate buggy sql.

How to repeat:
Open MySQL Workbench
Create a table
Go to Partitioning tab
Check Partition by list

Suggested fix:
Add the partitioning type COLUMNS
[26 Mar 2015 12:06] Miguel Solorzano
Thank you for the bug report. Please provide the project model file. Thanks.
[27 Mar 2015 2:48] Hailin Hu
model file

Attachment: mydb.mwb (application/octet-stream, text), 4.32 KiB.

[15 May 2015 13:20] Umesh Shastry
Thank you for the report.

I'm not seeing this issue on latest builds WB 6.3.3/6.2.5(confirmed on Win7, Mac OS X Mavericks, btw attached model file is empty) - Please note that if you wish to enable partitioning for your table check the "Enable Partitioning" check box. Doing this enables the partitioning options else that drop down list is grayed out. Please could you check out this at your end and inform us if you are still having issue with it. If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.

Thanks,
Umesh
[18 May 2015 8:26] Hailin Hu
models file

Attachment: mydb.mwb (application/octet-stream, text), 5.74 KiB.

[18 May 2015 8:27] Hailin Hu
screenshot

Attachment: スクリーンショット 2015-05-18 17.25.55.png (image/png, text), 54.33 KiB.

[18 May 2015 8:37] Hailin Hu
Sorry for the empty mwb file. I uploaded another one.

The issue is not about enable/disable partitioning, it's about a missing partitioning type. I attached another screenshot. The drop down list has not partitioning type COLUMNS(http://dev.mysql.com/doc/refman/5.6/en/partitioning-columns.html).

Also, the original creating sql is:
----
CREATE TABLE `persons` (
  `id` int(11) NOT NULL AUTO_INCREMENT,
  `gender` CHAR(1) NOT NULL,
  `name` VARCHAR(45),
  `created_at` TIMESTAMP NOT NULL DEFAULT CURRENT_TIMESTAMP,
  PRIMARY KEY (`id`, `gender`))
ENGINE = InnoDB
PARTITION BY LIST COLUMNS (`gender`) (
  PARTITION p0 VALUES IN ('F'),
  PARTITION p1 VALUES IN ('M'));

But the exported sql from mwb file is:
----
CREATE TABLE IF NOT EXISTS `mydb`.`persons` (
  `id` INT(11) NOT NULL AUTO_INCREMENT,
  `gender` CHAR(1) NOT NULL,
  `name` VARCHAR(45) NULL DEFAULT NULL,
  `created_at` TIMESTAMP NOT NULL DEFAULT CURRENT_TIMESTAMP,
  PRIMARY KEY (`id`, `gender`))
ENGINE = InnoDB
DEFAULT CHARACTER SET = latin1
COLLATE = latin1_swedish_ci PARTITION BY LIST() PARTITIONS 2( PARTITION p0 VALUES IN ('F'),  PARTITION p1 VALUES IN ('M'));

Finally, it seems that I have no permission to change the status to 'Open'. I can choose "Can't repeat" or "Closed" only.
[18 May 2015 9:24] Umesh Shastry
Thank you for the feedback.
Observed this on Win7 with WB 6.3.3.

Thanks,
Umesh
[28 Mar 2018 17:40] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.11 release, and here's the changelog entry:

Generated queries were incomplete for models that included table columns
of type VARCHAR with partitioning enabled.

Thank you for the bug report.