Bug #76174 mysql-apt-config hangs on upgrade (5.7 release)
Submitted: 5 Mar 2015 14:31 Modified: 13 Mar 2015 0:09
Reporter: Philip Antoniades Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Package Repos and Docker Images Severity:S3 (Non-critical)
Version:0.3.3-1ubuntu14.04 OS:Linux (Ubuntu 14.04.2 LTS)
Assigned to: CPU Architecture:Any

[5 Mar 2015 14:31] Philip Antoniades
Description:
Invoked in `aptitude upgrade` on desktop system, hung 30+m using ~50% of CPU (reported in top), stopped when sent a kill signal (SIGTERM). Re-running upgrade gave error: 

W: Failed to fetch http://repo.mysql.com/apt/ubuntu/dists/trusty/InRelease: Unable to find expected entry 'utilities-1.4/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)
E: Some index files failed to download. They have been ignored, or old ones used instead.

How to repeat:
Will update if I can.
[5 Mar 2015 14:32] Philip Antoniades
Not system critical.
[11 Mar 2015 9:39] Vishal Chaudhary
Hi Philip

Thanks for informing us about the bug.
We are in the process of fixing it.

It is be a duplicate of bug 76149 which can be tracked here :

http://bugs.mysql.com/bug.php?id=76149

Thanks
Vishal Chaudhary
[13 Mar 2015 0:09] Miguel Solorzano
Duplicate http://bugs.mysql.com/bug.php?id=76149.
[14 Mar 2015 7:11] Akhil Mohan
Hi Philip,

Thanks for the bug report. This issue has been resolved and more details are shared on bug http://bugs.mysql.com/bug.php?id=76149.

Please let us know if you need any assistance in setting up MySQL through our software repositories.

Akhil
[10 Oct 2015 17:37] John D'Orazio
I am getting this error again now, on Ubuntu 14.04 server:

W: Failed to fetch http://repo.mysql.com/apt/ubuntu/dists/trusty/InRelease  Unable to find expected entry 'mysql-utilities-1.6/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)

I looked at the solution indicated in the related issue 76149, but it did not fix.
[10 Oct 2015 18:19] John D'Orazio
I found that going through the configuration screen and selecting "mysql-utilities-1.5" instead of "mysql-utilities-1.6" will fix this error. I'm thinking it's perhaps because mysql-utilities-1.6 is incompatible with or not available for Ubuntu 14.04 server?
[12 Oct 2015 5:38] Lars Tangvald
Hi,

The issue is as you say that 1.6 shows up as a candidate. It is not available, so if selected the update will fail. The version of utilities currently available is 1.5.

Until we can release a fix, please make sure to pick utilities 1.5 from the version list.
[12 Oct 2015 15:32] Don Viszneki
Hi Vishal Chaudhary, Miguel Solorzano, and Akhil Mohan,

I do not believe this is related to Bug #76149.

Please explain how these two bugs can be related :)

Thank you!