Bug #76170 MySQL APT Repository bug/error, freezes/hangs
Submitted: 5 Mar 2015 10:57 Modified: 5 Mar 2015 11:04
Reporter: Remzi Cavdar Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Package Repos and Docker Images Severity:S1 (Critical)
Version:Latest stable version OS:Linux (Ubuntu 14.04.2 LTS)
Assigned to: CPU Architecture:Any
Tags: apt, freeze, hang, MySQL, mysql 5.6, MySQL APT, MySQL APT Repository

[5 Mar 2015 10:57] Remzi Cavdar
Description:
Dear Sir or Madam,

First of all my system information.
I'm running two computers with Ubuntu 14.04.2 LTS, one has a graphical desktop and the other not.
Both are servers.

I have done the following on both computers:
A long time ago I have installed the MySQL APT Repository and everything worked fine since then, but when I did a apt update command and upgrade command it freezes, it literary hangs and there is nothing I could do.

I did the following commands:

apt-get update
apt-get upgrade

See here under the output:

The following packages will be upgraded:
  mysql-apt-config
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 18.3 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://repo.mysql.com/apt/ubuntu/ trusty/mysql-apt-config mysql-apt-config all 0.3.3-1ubuntu14.04 [18.3 kB]
Fetched 18.3 kB in 0s (307 kB/s)
Preconfiguring packages ...
(Reading database ... 86568 files and directories currently installed.)
Preparing to unpack .../mysql-apt-config_0.3.3-1ubuntu14.04_all.deb ...
Unpacking mysql-apt-config (0.3.3-1ubuntu14.04) over (0.3.2-1ubuntu14.04) ...
Setting up mysql-apt-config (0.3.3-1ubuntu14.04) ...

After this there is no way turning back!
I already crashed one server :(
Please fix this, because this is a severe bug, I'm using MySQL 5.6 a stable version I suppose. 

How to repeat:
If you use the MySQL APT Repository for Ubuntu 14.04.2 LTS
and do the command: apt-get update

And after update the following command: apt-get upgrade

MySQL APT Repository guide: http://dev.mysql.com/doc/mysql-apt-repo-quick-guide/en/index.html

Suggested fix:
I don't know, I'm just a junior web developer who is able to setup my own servers, with a LAMP stack.
[5 Mar 2015 11:04] Umesh Shastry
Hello Remzi Cavdar,

Thank you for the report.
This is most likely duplicate of Bug #76149.

Thanks,
Umesh
[14 Mar 2015 7:09] Akhil Mohan
Hi Remzi,

This bug has been fixed and further details have been mentioned on http://bugs.mysql.com/bug.php?id=76149.

Hopefully this should help you setup your server properly. We would like to know how we can assist you in setting up MySQL on your server through our software repositories.

Akhil