Bug #76161 Apt-config not work
Submitted: 5 Mar 2015 4:15 Modified: 6 Mar 2015 17:39
Reporter: Yan WHK Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Package Repos and Docker Images Severity:S1 (Critical)
Version:0331 OS:Linux (Linux machine 3.16.0-31-generic #41~14.04.1-Ubuntu SMP Wed Feb 11 19:30:13 UTC 2015 x86_64 x86_64 x8)
Assigned to: CPU Architecture:Any

[5 Mar 2015 4:15] Yan WHK
Description:
Leaves no finish installation.

whk@machine:~$ sudo aptitude full-upgrade
...
Configurando mysql-apt-config (0.3.3-1ubuntu14.04) ...

And it does nothing more, spend hours and nothing.
Restart the PC and try to update the system tells me that it is impossible to run the update to finish fonfiguraciĆ³n the package was installed.

whk@machine:~$ sudo aptitude full-upgradewhk@machine:~$ sudo dpkg --configure -a
Configurando mysql-apt-config (0.3.3-1ubuntu14.04) ...

And it does nothing more, spend hours and nothing.

Attempt to remove the package and not let me finish setting up. Now not only was I without mysql-apt-config but I was unable to update any of my OS.

How to repeat:
Update ubuntu only :-/
[5 Mar 2015 4:19] Yan WHK
Dead here:

$ ps -aux

root      5336  0.0  0.0  75436  4220 pts/5    S+   01:10   0:00 sudo dpkg --configure -a
root      5337  0.0  0.0  27080 10624 pts/5    S+   01:10   0:00 dpkg --configure -a
root      5338 65.2  0.1  67528 16316 pts/5    R+   01:10   5:19 /usr/bin/perl -w /usr/share/debconf/frontend /var/lib/dpkg/info/mysql-apt-config.postinst configure 0.3.2-1ubuntu14.04
root      5344 42.3  0.0  16756  2596 pts/5    S+   01:10   3:27 /bin/bash /var/lib/dpkg/info/mysql-apt-config.config configure 0.3.2-1ubuntu14.04
[5 Mar 2015 4:34] Yan WHK
Dead to execute perl /usr/share/debconf/frontend:

my $confmodule=make_confmodule($config, "configure", $version);
[5 Mar 2015 4:42] Yan WHK
Perl script execute: /var/lib/dpkg/info/mysql-apt-config.postinst and dead in first exec line:

. /usr/share/debconf/confmodule
[5 Mar 2015 5:00] Umesh Shastry
Hello Yan WHK,

Thank you for the report.
This is most likely duplicate of Bug #76149

Thanks,
Umesh
[5 Mar 2015 10:44] Allan Jankins
This bug seems to be related to the config files being not purged (while there was a difference in the count of the possible entries).

WORKAROUND (after apt-get tries to install the package - I killed the process):

# dpkg -r mysql-apt-config
# dpkg -P mysql-apt-config
# dpkg -i /var/cache/apt/archives/mysql-apt-config_0.3.3-1ubuntu14.04_all.deb

Now it asked me for the settings interactively and the setup finished successfully.
[5 Mar 2015 12:03] Remzi Cavdar
After this I couldn't reinstall MySQL server, because also installing MySQL system tables takes ages.

This realse I a huge fail! The guys at MySQL clearly didn't test this out.
This S*^^cks, now I understand why a lot of folks don't update there system.

Now I also understand why most Linux distributions have there own flavor of MySQL.
[6 Mar 2015 17:39] Yan WHK
I have had many problems using the latest versions of mysql server and mysql workbench since I installed the apt-config, better will eliminate all and will use native packages repository ubuntu and my centos servers. This is a total disaster and production can not keep having these problems.
[14 Mar 2015 7:06] Akhil Mohan
Hi Yan/ Allan/ Remzi,

Thanks for using MySQL APT Repositories and also reporting this bug on the mysql-apt-config package.

We have resolved this problem and more details are available on the bug http://bugs.mysql.com/bug.php?id=76149. This is an isolated incident where we have let you down but let me assure you that we are making constant improvement in processes to assure quality.

Please let us know if your problems are sufficiently resolved with the provided fix.

Akhil
[14 Mar 2015 17:48] Remzi Cavdar
Hi Akhil,

Thank you for your reply, and I really hope that the team tests before it pushes out updates/upgrades, because we as web developers/system admins need to rely on the stable branch of the repository and if the core doesn't work properly then we have a problem.

Thanks for the notice/support.

Cheers,

Remzi
[18 Mar 2015 9:44] Akhil Mohan
Hi Remzi,

I agree on missing this important use case. We would try working on our processes around mysql-apt-config and hopefully this won't be repeated again.

Thanks,
Akhil
[18 Mar 2015 9:47] Remzi Cavdar
Hi Akhil,

Thanks for all your effort and quick answers.
I also hope that everything works fine for the production releases.

Again, thanks :)

Cheers,

Remzi