Bug #76150 First row hidden for large result set only when multiple rows require scrolling
Submitted: 4 Mar 2015 19:34 Modified: 14 Feb 2017 21:20
Reporter: Mike Reid Email Updates:
Status: Verified Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:6.3.9 OS:Mac OS X (10.12)
Assigned to: CPU Architecture:Any
Tags: first row, hidden row, result grid, results, sql editor

[4 Mar 2015 19:34] Mike Reid
Description:
When running a query returning multiple rows (enough to require scrolling in the results grid panel), I've noticed the first record in the results is not immediately visible. It is hidden behind the column labels and requires scrolling to reveal.

This does not happen for smaller record sets, only large ones spanning a height taller than the visible results panel.

NOTE: This was also happening prior to v6.2.5... I noticed around the time I switched to OS X Yosemite.

How to repeat:
1. Connect to database, open SQL Editor.

2. Run a SQL query returning a lot of records:
e.g. SHOW VARIABLES LIKE 'innodb_%';

3. Notice the first record in result set (indicated by small gray arrow) cannot be seen. It is hidden beneath the column labels.

4. Scroll up to reveal first record.

Suggested fix:
Adjust results display to ensure first record is visible for larger result sets, without requiring any additional action.
[4 Mar 2015 19:38] Mike Reid
Example of hidden first row after running a query.

Attachment: mysql_wb_bug_76150.png (image/png, text), 166.58 KiB.

[4 Mar 2015 20:41] Miguel Solorzano
Thank you for the bug report. Verified as described.
[5 Mar 2015 15:53] Mike Reid
This bug is also present in the v6.3.1-beta
[16 Mar 2015 16:04] Mike Reid
This bug is also present in the v6.3.2-rc.
[20 Mar 2015 16:26] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=76410 marked as duplicate of this one.
[24 Apr 2015 17:16] Mike Reid
Closing, as it appears this bug has been resolved.

I can no longer reproduce using latest MySQL Workbench v6.3.3 on OS X v10.10.3.
[5 Oct 2015 18:41] Mike Reid
Re-opening, it appears this bug is still present on v6.3.4 in latest versions of OS X (El Capitan)
[14 Feb 2017 21:20] Mike Reid
Bumping impacted version (still affects latest 6.3.9, also on latest macOS 10.12.0)
[25 Jun 2018 10:51] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=91390 marked as duplicate of this one.
[25 Jun 2018 10:59] Riwu Wang
Still not fixed on v8.0.11	.