Bug #76136 Run-time error '3146': ODBC--call failed.
Submitted: 3 Mar 2015 20:02 Modified: 28 Aug 2015 9:43
Reporter: Mihai Preda Email Updates:
Status: Can't repeat Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:5.1.13 OS:Microsoft Windows (Windows 7/8.1)
Assigned to: CPU Architecture:Any
Tags: 5.3.4, ODBC 5.1.13

[3 Mar 2015 20:02] Mihai Preda
Description:
When using MS Access as front end for MySQL via odbc connector versions 5.1.13 and 5.3.4, the odbc call fails with the error listed in the synopsis.

When I click on the debug button I get the following line highlighted:

sql = 'update table set field = 'value';

How to repeat:
This can be replicated if running Microsoft DAO 3.6 Object Library and MS Access 9.0 Object Library.

Have not tried to replicate using ADO or RDO code.

Suggested fix:
Odbc 5.1.12 and prior seem to work fine with DAO object libraries.
[3 Mar 2015 20:55] MySQL Verification Team
Thank you for the bug report. Same error reported on https://bugs.mysql.com/bug.php?id=57256. Looks like duplicate?. Thanks.
[4 Mar 2015 16:13] Mihai Preda
Thank you for pointing that our Miguel, but I don't think it's the same issue since we haven't had any problems with ODBC calls failing until ODBC Connector versions 5.1.13 and 5.3.4.
In fact our DSN accepts log in credentials and I think the DSN is created. It's the sql update, delete and insert functions that fail from what I can tell.
[10 Mar 2015 11:32] Chiranjeevi Battula
Hello Mihai Preda,

Thank you for your feedback.
Could you please provide us VB code sample, create table statements and ODBC trace to confirm this issue at our end?

Thanks,
Chiranjeevi.
[23 Mar 2015 3:38] Eric Black
Hi,

I am using MS access 2010 with mysql database
Software version: 5.5.42-cll - MySQL Community Server (GPL)
Protocol version: 10
Server charset: UTF-8 Unicode (utf8)

With ODBC 5.02.07 or 5.03.04, on querying the database, MS Access returns ODBC call failed.

However,  ODBC 5.1.11 works. I would use 5.1.11 but the issue is that it fails with long table names and the database I am connecting to has long table names.

your help is much appreciated.
[23 Mar 2015 6:41] Chiranjeevi Battula
Hello Eric Black,

Thank you for the bug report.
This is duplicate of Bug #65200 which is fixed in 5.2 version.  If you are still facing this issue in latest releases then please provide repeatable test case to reproduce the issue at our end.

Thanks,
Chiranjeevi.
[27 Mar 2015 1:32] Eric Black
ODBC - call failed

Attachment: mysql odbc error.JPG (image/jpeg, text), 20.46 KiB.

[27 Mar 2015 1:36] Eric Black
Hi,

I uploaded above the error that I am getting, which is call failed.

I know that the long table name issue was resolved, I was just pointing out that 5.1.11 does not cause the call failed error like the versions that resolved the long table name issue.
[28 Aug 2015 9:43] Chiranjeevi Battula
Hello Eric Black,

Thank you for your feedback.
I could not repeat this issue at my end with the provided information. 
If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.

Thanks,
Chiranjeevi.