Bug #7600 I can't configure an ODBC connection with a clean install - latest versions
Submitted: 31 Dec 2004 10:51 Modified: 6 Oct 2005 21:44
Reporter: Paul Jones Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:ODBC 3.5.1/MYSQL 4.1.8NT OS:Microsoft Windows (WIN XP)
Assigned to: Peter Harvey CPU Architecture:Any

[31 Dec 2004 10:51] Paul Jones
Description:
Hi

I just downloaded MYSQL and installed fine on a Win XP system. When I downloaded the ODBC drivers and tried to connect, I got
'Client does not support authentification protocol requested by server; consider upgrading MYSQL client'

Paul

How to repeat:
Install ODBC 3.5.1/MYSQL 4.1.8NT on XP

Suggested fix:
I've looked at all the posts in the ODBC forum and there are several posts about this over the past 3months. I tried the suggested fix of resetting passwords in mysql as old_password but this doesn't fix the problem.
[31 Dec 2004 16:28] Miguel Solorzano
Are you using Connector/ODBC 3.51.09 or earliest driver ? Then the issue
it wasn't linked against the 4.1 client library and was fixed with driver
3.51.10.
[31 Dec 2004 16:53] Paul Jones
Hi Miguel

Thanks for taking a look. I can confirm that I'm using 3.51.9 as that's the latest windows driver download showing on the downloads page today
http://dev.mysql.com/downloads/connector/odbc/3.51.html
[31 Dec 2004 17:42] Paul Jones
Hi

It is also throwing up error:
#1251 - Client does not support authentication protocol requested by server; consider upgrading MySQL client

when trying to connect with phpmyadmin
[1 Jan 2005 16:04] nicolas kerspern
Hi,

Happy holidays end of year !

Becarful, in the page http://dev.mysql.com/downloads/connector/odbc/3.51.html is wrong because in case Windows downloads, it say a version 3.51.9 and a not version 3.51.10 !! 
And I trying to download with a new version 3.51.10 and this file is not ready now :
http://dev.mysql.com/get/Downloads/MyODBC3/MyODBC-standard-3.51.10-win.exe/from/http://mir...

Thanks.

Nicolas. K
[6 Oct 2005 21:44] Mark Matthews
Fixed w/ ODBC-3.51.11 and later.