Bug #75831 Long FK name irretrievable
Submitted: 10 Feb 2015 0:39 Modified: 10 Feb 2015 10:02
Reporter: Matthew Nelson-White Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S3 (Non-critical)
Version:6.9.3 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[10 Feb 2015 0:39] Matthew Nelson-White
Description:
Within MySql.Data.Entity

"protected virtual MigrationStatement Generate(AddForeignKeyOperation op)" will generate a FK name using Guid.NewGuid() which breaks the "protected virtual MigrationStatement Generate(DropForeignKeyOperation op)" method because the FK name is not reproducable from the "ForeignKeyOperation" (DependentTable, DependentColumns, PrincipalTable) information

How to repeat:
Create and drop a Foreign key with a length greater than 64 characters.

Suggested fix:
Use a hash to reproduce the key name from the variables.

Like this...
http://pastebin.com/dvVRVpqp
[10 Feb 2015 10:02] Chiranjeevi Battula
Hello Matthew Nelson-White,

Thank you for the bug report.
This is duplicate of Bug #74726.

Thanks,
Chiranjeevi.