Bug #75712 Does not available for Fedora 21, F20 version does not run correctly
Submitted: 1 Feb 2015 9:42 Modified: 1 Feb 2015 19:13
Reporter: Álvaro Castillo Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version: OS:Linux (Fedora 21)
Assigned to: CPU Architecture:Any
Tags: bug, fix, new, upgrade

[1 Feb 2015 9:42] Álvaro Castillo
Description:
Fedora 21 does not have MySQL Workbench. It does not 'updated' for this version.

I try to install version of F20. It requires some dependencies of F20 that once time installed. I can launch Workbench. 

##############################
 rpm -ivh mysql-workbench-community-6.2.4-1.fc20.x86_64.rpm 
error: Failed dependencies:
	libctemplate.so.2()(64bit) is needed by mysql-workbench-community-6.2.4-1.fc20.x86_64
##############################

libctemplate.so is installed but the new version into F21. That's:

##############################
ctemplate-2.3-3.fc21.x86_64
[netSys@keys0 ~]$ rpm -ql ctemplate 
/usr/bin/diff_tpl_auto_escape
/usr/bin/make_tpl_varnames_h
/usr/bin/template-converter
/usr/lib64/libctemplate.so.3
/usr/lib64/libctemplate.so.3.0.0
/usr/lib64/libctemplate_nothreads.so.3
/usr/lib64/libctemplate_nothreads.so.3.0.0
/usr/share/doc/ctemplate
/usr/share/doc/ctemplate/AUTHORS
/usr/share/doc/ctemplate/COPYING
/usr/share/doc/ctemplate/ChangeLog
/usr/share/doc/ctemplate/NEWS
/usr/share/doc/ctemplate/README

#############################################

I have to download this lib from here: http://koji.fedoraproject.org/koji/buildinfo?buildID=455363

Copy into the system /usr/lib64 to work

#############################################

Setup

rpm -ivh --nodeps mysql-workbench*.rpm

##############################################

However, I cannot design tables on ERR. When I create a table. I cannot add fields on new tables. 

Screenshot: http://postimg.org/image/5f78acmvl/

How to repeat:
1. Download .rpm for F20 of ctemplate from here: http://koji.fedoraproject.org/koji/buildinfo?buildID=455363

2. Decompress .rpm into folder

3. Copy libctemplate.so.2 into /usr/lib64

4. Download MySQL Workbench from site

5. Install it with rpm -ivh --nodeps mysql-workbench*.rpm

6. Launch it 

7. Create new ERR

8. Add table

9. Try add fields into the table

Suggested fix:
Upgrade version of MySQL Workbench to support F21.
[1 Feb 2015 19:13] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=75421.