Bug #75680 InnoDB: unable to purge a record
Submitted: 29 Jan 2015 11:43 Modified: 10 Apr 2015 7:31
Reporter: Michael Brunnbauer Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S2 (Serious)
Version:5.5.41 OS:Linux (64bit)
Assigned to: CPU Architecture:Any

[29 Jan 2015 11:43] Michael Brunnbauer
Description:
hi all,

I found this in the MySQL log today:

150128  7:29:25  InnoDB: unable to purge a record
InnoDB: tuple DATA TUPLE: 2 fields;
 0: SQL NULL;
 1: len 26; hex 7777772e62657374646179657665726465766f6e2e636f2e756b; asc www.bestdayeverdevon.co.uk;;

InnoDB: record PHYSICAL RECORD: n_fields 2; compact format; info bits 32
 0: SQL NULL;
 1: len 26; hex 7777772e62657374646179657665726465766f6e2e636f2e756b; asc www.bestdayeverdevon.co.uk;;

space 126 offset 3619136 (1 records, index id 120)
InnoDB: Submit a detailed bug report to http://bugs.mysql.com

I am using mysql-5.5.41-linux2.6-x86_64.tar.gz downloaded from mysql.com

Is this serious? What should I do? More details on request.

How to repeat:
I was not yet able to reproduce.
[30 Jan 2015 1:37] zhai weixiang
duplicate of http://bugs.mysql.com/bug.php?id=73767  ?
[2 Feb 2015 10:17] Miguel Solorzano
Please check for duplicate with http://bugs.mysql.com/bug.php?id=73767 . Thanks.
[2 Feb 2015 10:42] Michael Brunnbauer
Miguel Solorzano wrote:
>Please check for duplicate with http://bugs.mysql.com/bug.php?id=73767 . Thanks.

Are you talking to me? How should I check if this is a duplicate of 73767?

Regards,

Michael Brunnbauer
[2 Feb 2015 11:20] Miguel Solorzano
Thank you for the feedback. That bug was fixed on 5.6.23 if you are able to test with it will help. Thanks.
[2 Feb 2015 11:36] Michael Brunnbauer
There are bugs that get fixed in 5.6 but not in 5.5? Why is that?

I will migrate to 5.6 then and see if the bug hits again.

What should I do about the affected table? Is it likely that is it corrupt?
I have started a "check table" command but it will probably take days as the
table is 600GB big.
[10 Feb 2015 11:14] Miguel Solorzano
Thank you for the feedback. Please re-open this bug report when you get results with 5.6. Thanks.
[10 Feb 2015 11:40] Michael Brunnbauer
So far no problems with 5.6.23. Let's wait some weeks if something turns up.

It's great how you avoid answering my questions! BTW the check table command did not show any problems.
[10 Apr 2015 7:31] Umesh Shastry
Marking as duplicate of Bug #73767