Bug #75658 Cannot edit table data in model
Submitted: 27 Jan 2015 18:21 Modified: 18 Mar 2015 14:38
Reporter: Miguel Mello Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S1 (Critical)
Version:6.2.4 OS:Linux (Fedora release 21 Twenty One)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[27 Jan 2015 18:21] Miguel Mello
Description:
When opening a table for editing, nothing shows in columns panel. Follow the log content:

16:14:03 [INF][      WBContext]: Parsing application arguments.
16:14:03 [INF][      WBContext]:     /usr/libexec/mysql-workbench/mysql-workbench-bin
16:14:03 [INF][   base library]: Notification GNUIFormCreated is not registered
16:14:03 [INF][   WBContext UI]: Initializing workbench context UI with these values:
	base dir: /usr/share/mysql-workbench
	plugin path: /usr/lib64/mysql-workbench/plugins
	struct path: /usr/share/mysql-workbench/grt
	module path: /usr/lib64/mysql-workbench/modules
	library path: /usr/share/mysql-workbench/libraries
	user data dir: /home/miguel/.mysql/workbench
	open at start: 
	open type: 
	run at startup: 
	run type: 
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
16:14:03 [INF][      WBContext]: WbContext::init
16:14:03 [WRN][WBFabric Module]: Unable to locate the mysqlfabric utility, the fabric functions will not be available. 
Please make sure MySQL Utilities version 1.4.3 or higher is installed. 
The mysqlfabric utility path should be added into the PATH environment variable: which: no mysqlfabric in (/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin)
16:14:03 [INF][            WBA]: Looking for extension modules for WBA...
16:14:03 [INF][            WBA]: 0 extension modules found
16:14:03 [WRN][            grt]: /usr/share/mysql-workbench/data/table_templates.xml:21: link 'com.mysql.rdbms.mysql.datatype.timestamp' <object db.SimpleDatatype> key=simpleType could not be resolved
16:14:03 [WRN][            grt]: /usr/share/mysql-workbench/data/table_templates.xml:106: link 'com.mysql.rdbms.mysql.datatype.varchar' <object db.SimpleDatatype> key=simpleType could not be resolved
16:14:04 [WRN][            grt]: /usr/share/mysql-workbench/data/table_templates.xml:229: link 'com.mysql.rdbms.mysql.datatype.int' <object db.SimpleDatatype> key=simpleType could not be resolved
16:14:04 [WRN][            grt]: /home/miguel/.mysql/workbench/connections.xml:26: link '48f82380-a64d-11e4-a120-645a0402e2c0' <object GrtObject> key=owner could not be resolved
16:14:04 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Linux/Unix version 6.2.4  revision 12437 build 2426 (64 bit)
	Configuration Directory: /home/miguel/.mysql/workbench
	Data Directory: /usr/share/mysql-workbench
	Cairo Version: 1.13.1
	OS: Linux 3.18.3-201.fc21.x86_64
	CPU: 8x Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz (3246.937MHz) - 15.64GiB RAM
	Distribution: Fedora release 21 (Twenty One)

16:14:04 [INF][   base library]: Notification GNUIFormCreated is not registered
16:14:05 [INF][   base library]: Notification GNUIFormCreated is not registered
16:14:06 [INF][   base library]: Notification GNUIFormCreated is not registered
16:14:08 [INF][   base library]: Notification GNUIFormCreated is not registered

How to repeat:
Try to edit a table in a model.

Suggested fix:
Columns should show properly in panel.
[1 Feb 2015 19:42] Miguel Solorzano
Thank you for the bug report.
[27 Feb 2015 17:35] Miguel Solorzano
bugs.mysql.com/bug.php?id=76079 marked as duplicate of this one.
[8 Mar 2015 13:19] Miguel Mello
I just installed version 6.2.5 and got back editing table columns again. The Paramiko problem when connecting through SSH, seems to be solved indeed.
[18 Mar 2015 14:38] Marcin Szalowicz
Thank you for the feedback.

fixed in 6.2.5 as confirmed by the author of the bug.