Bug #75488 VS2013 template: MySQL Windows Forms Project
Submitted: 13 Jan 2015 10:47 Modified: 16 Oct 2015 7:02
Reporter: Guy Heylens Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Visual Studio Integration Severity:S2 (Serious)
Version:Connector 6.9.5 OS:Windows (8.1)
Assigned to: CPU Architecture:Any
Tags: template, VS2013

[13 Jan 2015 10:47] Guy Heylens
Description:
When creating a new project in Visual Studio 2013 and hereby selecting the template Templates->MySQL->"MySQL Windows Forms Project" Visual Studio starts to create a new project and then crashes.

--------------------------------------------------
ERROR:

System.FormatException was unhandled
Message: An unhandled exception of type 'System.FormatException' occurred in mscorlib.dll
Additional information: Input string was not in a correct format.

--------------------------------------------------
--------------------------------------------------
Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.51641

Installed Version: Professional

MySQL for Visual Studio   1.2.3
Data design and management tools for MySQL.  Copyright © 2007-2014 Oracle, Inc.

How to repeat:
Open Visual Studio 2013
Create new Project
Select Templates->Visual Basic->MySQL->MySQL Windows Forms Project

------------------------------------------------------------------

Open Visual Studio 2013
Create new Project
Select Templates->Visual C#->MySQL->MySQL Windows Forms Project

------------------------------------------------------------------

Open Visual Studio 2013
Create new Project
Select Templates->Visual BASIC->MySQL->MySQL ASP.NET MVC Project
------------------------------------------------------------------

Open Visual Studio 2013
Create new Project
Select Templates->Visual C#->MySQL->MySQL ASP.NET MVC Project

Suggested fix:
Don't know how templates work. Would be a great help though if we could immediately create a MySQL project from the template.
[13 Jan 2015 10:49] Guy Heylens
Visual Studio 2013 create new project screenshot.

Attachment: vs2013_mysql.jpg (image/jpeg, text), 123.93 KiB.

[14 Jan 2015 11:43] Chiranjeevi Battula
Hello Guy Heylens,

Thank you for the bug report.
I tried to reproduce the issue at my end using Visual Studio 2013, MySQL for Visual Studio 1.2.3 and EF Version : MySql.Data.Entity.EF6 (6.9.5.0) but Couldn't trace out any issue.

Thanks,
Chiranjeevi.
[14 Jan 2015 11:44] Chiranjeevi Battula
screenshots

Attachment: Screenshots.zip (application/zip, text), 142.87 KiB.

[15 Feb 2015 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[16 Feb 2015 5:36] Chiranjeevi Battula
Bug#75884 marked as duplicate of this one.
[27 Aug 2015 13:04] Andrew K
I have this bug too.
Windows 10
Visual Studio 2013 sp5
mysql-connector-net-6.9.7
mysql-for-visualstudio-1.2.4
[25 Sep 2015 13:37] Jan Veres
I have same error...

Error log from Event Viewer:

Application: devenv.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.FormatException
Stack:
   at System.Number.ParseDouble(System.String, System.Globalization.NumberStyles, System.Globalization.NumberFormatInfo)
   at MySql.Data.VisualStudio.Wizards.WindowsForms.DataAccessConfig.OnStarting(MySql.Data.VisualStudio.Wizards.BaseWizardForm)
   at MySql.Data.VisualStudio.Wizards.BaseWizardForm.BaseWizardForm_Load(System.Object, System.EventArgs)
   at MySql.Data.VisualStudio.Wizards.WindowsForms.WindowsFormsWizardForm.WizardForm_Load(System.Object, System.EventArgs)
   at System.Windows.Forms.Form.OnLoad(System.EventArgs)
   at System.Windows.Forms.Form.OnCreateControl()
   at System.Windows.Forms.Control.CreateControl(Boolean)
   at System.Windows.Forms.Control.CreateControl()
   at System.Windows.Forms.Control.WmShowWindow(System.Windows.Forms.Message ByRef)
   at System.Windows.Forms.Control.WndProc(System.Windows.Forms.Message ByRef)
   at System.Windows.Forms.ScrollableControl.WndProc(System.Windows.Forms.Message ByRef)
   at System.Windows.Forms.Form.WmShowWindow(System.Windows.Forms.Message ByRef)
   at System.Windows.Forms.Form.WndProc(System.Windows.Forms.Message ByRef)
   at System.Windows.Forms.Control+ControlNativeWindow.OnMessage(System.Windows.Forms.Message ByRef)
   at System.Windows.Forms.Control+ControlNativeWindow.WndProc(System.Windows.Forms.Message ByRef)
   at System.Windows.Forms.NativeWindow.DebuggableCallback(IntPtr, Int32, IntPtr, IntPtr)
   at System.Windows.Forms.SafeNativeMethods.ShowWindow(System.Runtime.InteropServices.HandleRef, Int32)
   at System.Windows.Forms.Control.SetVisibleCore(Boolean)
   at System.Windows.Forms.Form.SetVisibleCore(Boolean)
   at System.Windows.Forms.Control.set_Visible(Boolean)
   at System.Windows.Forms.Application+ThreadContext.RunMessageLoopInner(Int32, System.Windows.Forms.ApplicationContext)
   at System.Windows.Forms.Application+ThreadContext.RunMessageLoop(Int32, System.Windows.Forms.ApplicationContext)
   at System.Windows.Forms.Application.RunDialog(System.Windows.Forms.Form)
   at System.Windows.Forms.Form.ShowDialog(System.Windows.Forms.IWin32Window)
   at System.Windows.Forms.Form.ShowDialog()
   at MySql.Data.VisualStudio.Wizards.BaseWizard`2[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].RunStarted(System.Object, System.Collections.Generic.Dictionary`2<System.String,System.String>, Microsoft.VisualStudio.TemplateWizard.WizardRunKind, System.Object[])
   at MySql.Data.VisualStudio.Wizards.WindowsForms.WindowsFormsWizard.RunStarted(System.Object, System.Collections.Generic.Dictionary`2<System.String,System.String>, Microsoft.VisualStudio.TemplateWizard.WizardRunKind, System.Object[])
   at Microsoft.VisualStudio.TemplateWizard.Wizard.Execute(System.Object, Int32, System.Object[] ByRef, System.Object[] ByRef, EnvDTE.wizardResult ByRef)
   at EnvDTE100.Solution4.AddFromTemplateEx(System.String, System.String, System.String, System.String, Boolean, UInt32)
   at Microsoft.VisualStudio.Dialogs.ServiceHelper.AddProjectFromSelectedTemplate(Microsoft.VisualStudio.Dialogs.INewProjectDialogData, System.String, Boolean)
   at Microsoft.VisualStudio.Dialogs.SVsDialogService.CreateProject(Microsoft.VisualStudio.Dialogs.INewProjectDialogData)
   at Microsoft.VisualStudio.Dialogs.SVsDialogService.InvokeDialog(Microsoft.Internal.VisualStudio.Shell.Interop.VSNEWPROJECTDLGINFO, System.String ByRef)
[16 Oct 2015 7:02] Chiranjeevi Battula
Hello  Andrew,

Thank you for your feedback.
I could not repeat this issue at my end with the provided information. 
If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.

Thanks,
Chiranjeevi.