Bug #75304 InnoDB: Assertion failure in thread 140325136348928 in file btr0pcur.cc line 251
Submitted: 24 Dec 2014 5:51 Modified: 24 Dec 2014 7:19
Reporter: Nirav Patel Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S1 (Critical)
Version:5.5.19 OS:Linux
Assigned to: CPU Architecture:Any
Tags: InnoDB: Assertion failure

[24 Dec 2014 5:51] Nirav Patel
Description:
I am getting below error while executing SELECT statement. After referring many blogs and forums don't get any permanent solution for that. Please suggest solution.

2014-12-22 17:20:47 7f9ffde7b700  InnoDB: Assertion failure in thread 140325136348928 in file btr0pcur.cc line 251
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
11:50:47 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.

How to repeat:
There is no particular steps to repeat it
[24 Dec 2014 7:19] Umesh Shastry
Hello Nirav,

Thank you for the report, this is duplicate of Bug #68051 which is fixed in 5.1.69, 5.5.31, 5.6.11, 5.7.1.
Please note that we do not fix bugs that are not repeatable with current versions and also, version 5.5.19 is very old and many bugs were
fixed since. Please upgrade to current version 5.5.41/5.6.22, try with it and if this issue still exists then inform us with exact repeatable test case.

Thanks,
Umesh Shastry