Bug #75171 MySQLInstallerConsole - Configuration file was not found
Submitted: 11 Dec 2014 5:38 Modified: 9 Oct 2015 22:29
Reporter: BSOD 2600 Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Server: Installing Severity:S1 (Critical)
Version:5.6.26.0, 5.6.27 OS:Microsoft Windows (Server 2008 R2)
Assigned to: CPU Architecture:Any

[11 Dec 2014 5:38] BSOD 2600
Description:
The MySQL 5.6.21.1 and 5.6.22.0 MSI installers do not properly install themselves so MySQLInstallerConsole will function.   When attempting to use MySQLInstallerConsole it reports:
Configuration file was not found. Please reinstall a MySQL Installer bundle.

mysql-installer-community-5.6.20.0.msi correctly works. 

Demo of 5.6.20 success: http://i1.minus.com/jPeEklEFI75Wx.png
Demo of 5.6.22 failure: http://i.minus.com/jbyI2PcKQNFnHB.png

How to repeat:
C:\>msiexec /i mysql-installer-community-5.6.22.0.msi /qn

C:\>cd C:\Program Files (x86)\MySQL\MySQL Installer for Windows

C:\Program Files (x86)\MySQL\MySQL Installer for Windows>MySQLInstallerConsole.exe --config=mysql-server-5.6-winx64:passwd=mypw;servertype=server;enabletcpip=true;port=3306;openfirewall=true;servicename=MySQL;slowlog=true --user=mysql-server-5.6-winx64:name=cactiuser;host=localhost;role=DBA;password=mypw --product=mysql-server-5.6 --catalog=mysql-5.6-winx64 --action=install --nowait
=================== Start Initialization ===================
MySQL Installer is running in Commercial mode.

<receive error message pop up window here>
[11 Dec 2014 5:42] BSOD 2600
mysql 5.6.20 - success

Attachment: mysql 5.6.20 installerconsole.png (image/png, text), 22.37 KiB.

[11 Dec 2014 5:42] BSOD 2600
mysql 5.6.22 - failure

Attachment: mysql 5.6.22 installerconsole.png (image/png, text), 23.60 KiB.

[12 Feb 2015 16:54] Shyamal Parikh
I am having a similar problem. 

I am not able to run the msi in silent mode. It only works in a passive or user interaction mode.

I am really doubtful if 5.6.20.0 supports silent mode installation
[30 Jun 2015 3:53] BSOD 2600
Simular problem with MySQL 5.6.25.0 on Windows.  Running the same MySQLInstallerConsole documented before, now there is no error -- but nothing gets installed either.  

Furthermore, when manually running MySQLInstaller.exe, selecting any Setup Type and clicking "Next", the following error is displayed: 
"Unable to determine the products that correspond with that setup type."

Thus, the installer IS STILL BROKEN!
[18 Aug 2015 12:21] Chiranjeevi Battula
Hello  BSOD,

Thank you for the bug report.
I could not reproduce this issue at my end using latest MySQLInstallerConsole.exe.
Could you please list out exact steps you tried out at your end, this would help us to reproduce the issue at our end.

Thanks,
Chiranjeevi.
[19 Aug 2015 2:52] BSOD 2600
Hello Chiranjeevi,

I attempted to repro it with the current 5.6.26.0 version and now ran into an issue with the config options (which worked with 5.6.20).  Below are steps and output.

-----------------
C:\>msiexec /i mysql-installer-community-5.6.26.0.msi /qn

C:\>cd C:\Program Files (x86)\MySQL\MySQL Installer for Windows

C:\Program Files (x86)\MySQL\MySQL Installer for Windows>MySQLInstallerConsole.exe --config=mysql-server-5.6-winx64:passwd=mypw;servertype=server;enabletcpip=true;port=3306;openfirewall=true;servicename=MySQL;slowlog=true --user=mysql-server-5.6-winx64:name=cactiuser;host=localhost;role=DBA;password=mypw --product=mysql-server-5.6 --catalog=mysql-5.6-winx64 --action=install --nowait
=================== Start Initialization ===================
MySQL Installer is running in Commercial mode.

Initializing product requirements
Loading product catalog
Checking for product catalog snippets
Checking for product packages in the bundle
Categorizing product catalog
Finding all installed packages.
Initializing product requirements
Loading product catalog
Checking for product catalog snippets
Checking for product packages in the bundle
Categorizing product catalog
Finding all installed packages.
Your product catalog was last updated at 8/18/2015 7:30:44 PM
=================== End Initialization ===================

--config=mysql-server-5.6-winx64:passwd=mypw;servertype=server;enabletcpip=true;port=3306;openfirewall=true;servicename=MySQL;slowlog=true is not a supported action.

C:\Program Files (x86)\MySQL\MySQL Installer for Windows>
[19 Aug 2015 3:15] BSOD 2600
Another minor bug -- the installer doesn't select the current version.  In the example below, it selected 5.6.25 -- instead of 5.6.26.

Simplifying the installer command to almost use whats in the documentation (http://dev.mysql.com/doc/mysql-installer/en/MySQLInstallerConsole.html)

C:\Program Files (x86)\MySQL\MySQL Installer for Windows>MySQLInstallerConsole.exe install server;5.6;x64
=================== Start Initialization ===================
MySQL Installer is running in Commercial mode.

Initializing product requirements
Loading product catalog
Checking for product catalog snippets
Checking for product packages in the bundle
Categorizing product catalog
Finding all installed packages.
Your product catalog was last updated at 8/18/2015 7:30:44 PM
=================== End Initialization ===================

Install MySQL Server 5.6.25-X64? [Y/N]n
Install MySQL Server 5.6.24-X64? [Y/N]n
Install MySQL Server 5.6.23-X64? [Y/N]^C
[6 Oct 2015 9:35] Chiranjeevi Battula
Hello  BSOD,

Thank you for your feedback.
Verified this behavior on MySQL for Windows installer with 1.4.11 version.

Thanks,
Chiranjeevi.
[6 Oct 2015 9:36] Chiranjeevi Battula
C:\>msiexec /i mysql-installer-community-5.6.27.0.msi /qn

C:\>cd C:\Program Files (x86)\MySQL\MySQL Installer for Windows

C:\Program Files (x86)\MySQL\MySQL Installer for Windows>MySQLInstallerConsole.exe --config=mysql-server-5.6-winx64:passwd=mypw;servertype=server;enab
letcpip=true;port=3306;openfirewall=true;servicename=MySQL;slowlog=true --user=mysql-server-5.6-winx64:name=cactiuser;host=localhost;role=DBA;password
=mypw --product=mysql-server-5.6 --catalog=mysql-5.6-winx64 --action=install --nowait
=================== Start Initialization ===================
MySQL Installer is running in Commercial mode

Attempting to update manifest.
Initializing product requirements
Loading product catalog
Checking for product catalog snippets
Checking for product packages in the bundle
Categorizing product catalog
Finding all installed packages.
Attempting to update manifest.
Initializing product requirements
Loading product catalog
Checking for product catalog snippets
Checking for product packages in the bundle
Categorizing product catalog
Finding all installed packages.
Your product catalog was last updated at 10/6/2015 2:49:45 PM
=================== End Initialization ===================

--config=mysql-server-5.6-winx64:passwd=mypw;servertype=server;enabletcpip=true;port=3306;openfirewall=true;servicename=MySQL;slowlog=true is not a su
pported action.

C:\Program Files (x86)\MySQL\MySQL Installer for Windows>
C:\Program Files (x86)\MySQL\MySQL Installer for Windows>MySQLInstallerConsole.exe install server;5.6;x64
=================== Start Initialization ===================
MySQL Installer is running in Commercial mode

Attempting to update manifest.
Initializing product requirements
Loading product catalog
Checking for product catalog snippets
Checking for product packages in the bundle
Categorizing product catalog
Finding all installed packages.
Your product catalog was last updated at 10/6/2015 2:49:45 PM
=================== End Initialization ===================

Install MySQL Server 5.6.26-X64? [Y/N]N
Install MySQL Server 5.6.25-X64? [Y/N]N
Install MySQL Server 5.6.24-X64? [Y/N]N
Install MySQL Server 5.6.23-X64? [Y/N]N
Install MySQL Server 5.6.22-X64? [Y/N]^C
C:\Program Files (x86)\MySQL\MySQL Installer for Windows>
[9 Oct 2015 22:28] Jose Gabriel Valencia Ornelas
Posted by developer:
 
The original bug was fixed in a previous version of the installer

the message that the configuration file doesn't exists is because the CLI was not applying the catalog, this was happening the first time was used, but now the CLI applies the catalog if is necessary (only found NewManifest.zip file) 

the older arguments used on installer 1.3.X are no longer supported, is necessary to read the documentation and update the argument blocks.

Is highly encouraged to use one bug for every issue founded and not mix one bug with more than one issue, the other issue about not displaying or allowing to install the server version that is shipped in the installer bundle was moved to another bug http://bugs.mysql.com/bug.php?id=78792 as a quick reference this issue have two workarounds for now, do an update to the catalog or specify exactly the server version (5.6.27 for example) for further information see the bug that was created

the following text is an argument that is well formed, cotnain blocks to configure not only the server but also additional ussers and specify to install 5.6.27 without problems (remember the paths needs to be enclosed in double quotes always)

install server;5.6.23;x64:*:type=config;openfirewall=true;generallog=true;binlog=true;serverid=3306;enable_tcpip=true;port=3306;rootpasswd=root;installdir="c:\MySQL\MySQL Server 5.6";datadir="c:\MySQL 5.6 Data":type=user;username=user;password=password;role=DBManager