Bug #75138 Still get "Connection using old (pre-4.1.1) authentication protocol refused"
Submitted: 8 Dec 2014 11:02 Modified: 26 Aug 2015 23:48
Reporter: David Hartfield Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.1 OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any

[8 Dec 2014 11:02] David Hartfield
Description:
In order to stop getting the following error message when connecting to a db with an older password hash: 
"Connection using old (pre-4.1.1) authentication protocol refused (client option 'secure_auth' enabled)"
, I selected the "Use old authentication protocol." option under the Advanced tab of the Connection settings. I see that update was kindly made at the request in this issue #70023

That works for connecting and most operations with the db; however, I still get the error when I go to do an export or an import:

"ERROR 2049 (HY000): Connection using old (pre-4.1.1) authentication protocol refused (client option 'secure_auth' enabled)
Operation failed with exitcode 1"

This disallows a key use of MySQL Workbench for me.

How to repeat:
Connect to a server using pre-4.1.1 authentication, by setting "Use old authentication protocol" under the Advanced tab of Connection Settings.
Attempt to import, or export data.

Suggested fix:
Setup the import & export services to use the configured authentication method set in the connection settings.
[26 Aug 2015 23:48] Miguel Solorzano
Duplicate of http://bugs.mysql.com/bug.php?id=74165.
[26 Aug 2015 23:49] Miguel Solorzano
Sorry I meant http://bugs.mysql.com/bug.php?id=78060.