Bug #75052 foreign-keys testcase mismerged in 5.5
Submitted: 1 Dec 2014 6:59 Modified: 15 May 2019 12:56
Reporter: Laurynas Biveinis (OCA) Email Updates:
Status: Won't fix Impact on me:
None 
Category:Tests: Server Severity:S3 (Non-critical)
Version:5.5, 5.5.42 OS:Any
Assigned to: CPU Architecture:Any
Tags: bzr

[1 Dec 2014 6:59] Laurynas Biveinis
Description:
5.5 $ bzr revno
4736

5.5 $ find . -name *.moved
./mysql-test/suite/innodb/r/foreign-keys.result.moved
./mysql-test/suite/innodb/t/foreign-keys.test.moved

5.5 $ diff -u mysql-test/suite/innodb/t/foreign-keys.test mysql-test/suite/innodb/t/foreign-keys.test.moved 
--- mysql-test/suite/innodb/t/foreign-keys.test	2014-11-28 14:40:07.000000000 +0200
+++ mysql-test/suite/innodb/t/foreign-keys.test.moved	2014-11-28 14:40:07.000000000 +0200
@@ -10,9 +10,9 @@
 PRIMARY KEY (`department_id`)) engine=innodb;
 
 CREATE TABLE `title` (`title_id` INT, `title_manager_fk` INT,
-`title_reporter_fk` INT, PRIMARY KEY (`title_id`)) engine=innodb;
+`title_reporter_fk` INT, PRIMARY KEY (`title_id`));
 
-CREATE TABLE `people` (`people_id` INT, PRIMARY KEY (`people_id`)) engine=innodb;
+CREATE TABLE `people` (`people_id` INT, PRIMARY KEY (`people_id`));
 
 ALTER TABLE `department` ADD FOREIGN KEY (`department_people_fk`) REFERENCES
 `people` (`people_id`);

5.5 $ diff -u mysql-test/suite/innodb/r/foreign-keys.result mysql-test/suite/innodb/r/foreign-keys.result.moved 
--- mysql-test/suite/innodb/r/foreign-keys.result	2014-11-28 14:40:07.000000000 +0200
+++ mysql-test/suite/innodb/r/foreign-keys.result.moved	2014-11-28 14:40:07.000000000 +0200
@@ -5,8 +5,8 @@
 CREATE TABLE `department` (`department_id` INT, `department_people_fk` INT,
 PRIMARY KEY (`department_id`)) engine=innodb;
 CREATE TABLE `title` (`title_id` INT, `title_manager_fk` INT,
-`title_reporter_fk` INT, PRIMARY KEY (`title_id`)) engine=innodb;
-CREATE TABLE `people` (`people_id` INT, PRIMARY KEY (`people_id`)) engine=innodb;
+`title_reporter_fk` INT, PRIMARY KEY (`title_id`));
+CREATE TABLE `people` (`people_id` INT, PRIMARY KEY (`people_id`));
 ALTER TABLE `department` ADD FOREIGN KEY (`department_people_fk`) REFERENCES
 `people` (`people_id`);
 ALTER TABLE `title` ADD FOREIGN KEY (`title_manager_fk`) REFERENCES `people`

Introduced by

------------------------------------------------------------
revno: 4717 [merge]
author: murthy.narkedimilli@oracle.com
committer: Murthy Narkedimilli <murthy.narkedimilli@oracle.com>
branch nick: mysql-5.5
timestamp: Tue 2014-09-23 08:51:23 +0200
message:
  Merge from mysql-5.5.40-release
------------------------------------------------------------

How to repeat:
See above

Suggested fix:
Merge the testcase properly
[1 Dec 2014 7:29] Umesh Shastry
Hello Laurynas Biveinis,

Thank you for the report.

Thanks,
Umesh
[1 Dec 2014 7:30] Umesh Shastry
// from latest pb

commit: 4e060e8a6583d531488265ce6fb0b2765f06f4bd
date: 2014-11-28 10:26:38 +0100
build-date: 2014-11-28 23:47:02 +0100
short: 4e060e8
branch: mysql-5.5

MySQL source 5.5.42
[umshastr@hod03]/export/umesh/mysql-5.5.42: find . -name *.moved
./mysql-test/suite/innodb/t/foreign-keys.test.moved
./mysql-test/suite/innodb/r/foreign-keys.result.moved
[umshastr@hod03]/export/umesh/mysql-5.5.42:
[umshastr@hod03]/export/umesh/mysql-5.5.42: diff -u mysql-test/suite/innodb/t/foreign-keys.test mysql-test/suite/innodb/t/foreign-keys.test.moved
--- mysql-test/suite/innodb/t/foreign-keys.test 2014-11-28 23:53:35.000000000 +0100
+++ mysql-test/suite/innodb/t/foreign-keys.test.moved   2014-11-28 23:53:35.000000000 +0100
@@ -10,9 +10,9 @@
 PRIMARY KEY (`department_id`)) engine=innodb;

 CREATE TABLE `title` (`title_id` INT, `title_manager_fk` INT,
-`title_reporter_fk` INT, PRIMARY KEY (`title_id`)) engine=innodb;
+`title_reporter_fk` INT, PRIMARY KEY (`title_id`));

-CREATE TABLE `people` (`people_id` INT, PRIMARY KEY (`people_id`)) engine=innodb;
+CREATE TABLE `people` (`people_id` INT, PRIMARY KEY (`people_id`));

 ALTER TABLE `department` ADD FOREIGN KEY (`department_people_fk`) REFERENCES
 `people` (`people_id`);
[umshastr@hod03]/export/umesh/mysql-5.5.42:
[umshastr@hod03]/export/umesh/mysql-5.5.42: diff -u mysql-test/suite/innodb/r/foreign-keys.result mysql-test/suite/innodb/r/foreign-keys.result.moved
--- mysql-test/suite/innodb/r/foreign-keys.result       2014-11-28 23:53:35.000000000 +0100
+++ mysql-test/suite/innodb/r/foreign-keys.result.moved 2014-11-28 23:53:35.000000000 +0100
@@ -5,8 +5,8 @@
 CREATE TABLE `department` (`department_id` INT, `department_people_fk` INT,
 PRIMARY KEY (`department_id`)) engine=innodb;
 CREATE TABLE `title` (`title_id` INT, `title_manager_fk` INT,
-`title_reporter_fk` INT, PRIMARY KEY (`title_id`)) engine=innodb;
-CREATE TABLE `people` (`people_id` INT, PRIMARY KEY (`people_id`)) engine=innodb;
+`title_reporter_fk` INT, PRIMARY KEY (`title_id`));
+CREATE TABLE `people` (`people_id` INT, PRIMARY KEY (`people_id`));
 ALTER TABLE `department` ADD FOREIGN KEY (`department_people_fk`) REFERENCES
 `people` (`people_id`);
 ALTER TABLE `title` ADD FOREIGN KEY (`title_manager_fk`) REFERENCES `people`
[15 May 2019 12:56] Dmitry Lenev
Posted by developer:
 
Hello!

The issue affects 5.5 tree only. There is no .moved files in 5.6 tree
(since in 5.6 test for the original bug is called differently/is a bit
different).

Since the issue is test-only and 5.5 is under Oracle Sustaining Support
now, I think it is infeasible to fix it. Closing this bug report as such.