Bug #74894 Failure to connect to MySQL Fabric from a windows installed workbench.
Submitted: 17 Nov 2014 7:58 Modified: 16 Feb 2016 8:59
Reporter: Richard Sumption Email Updates:
Status: Verified Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.2.3.12312 Build 2280 64bit OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: fabric

[17 Nov 2014 7:58] Richard Sumption
Description:
I have 2 MySQL Fabric clusters running on both RedHat 6.5 & Centos 6.5 - all functions correctly, however when I try to connect using Workbench on my windows machine 7 (64bit) to access the cluster, I get 2 different error messages 
   1. when I enter the group_id in options
      "Unexpected error while connecting to fabric node."
   2. with no group_id specified.
      "Unexpected error on fabric operation: group lookup_groups"
I have screenshots of the error messages.
Mysql version:
   mysql  Ver 14.14 Distrib 5.6.21, for Linux (x86_64)
mysql-utilities version (server): 1.5.3
mysql-utilities (windows)       : 1.5.3 

How to repeat:
I have a network (Redhat) Fabric cluster, and a local PC Generated (Centos) Fabric cluster. Both give the same error.

Suggested fix:
?
[17 Nov 2014 8:50] Richard Sumption
error when group_id is specified

Attachment: workbench error message.bmp (image/bmp, text), 354.62 KiB.

[17 Nov 2014 8:50] Richard Sumption
error when group_id is not specified

Attachment: workbench error message2.bmp (image/bmp, text), 423.24 KiB.

[17 Nov 2014 8:51] Richard Sumption
Forgot to mention the group_id is fabric01
[1 Dec 2014 10:36] Richard Sumption
the Scripts used to create the Fabric cluster are available online in :-
   https://github.com/RichardSumption
[28 Apr 2015 21:01] Miguel Solorzano
Please check version 6.3.3. Thanks.
[14 May 2015 23:36] Naresh Mote
The lastest version of MySQL Workbench 6.3.3 too is not working for fabric connection. No error is been prompted. The bug still exists.
[2 Jun 2015 20:45] Naresh Mote
Workbench6.3.3_ConnectionError_4_Fabric

Attachment: WrkbnchFabrcerror.JPG (image/jpeg, text), 24.91 KiB.

[15 Jan 2016 0:22] Naresh Mote
Hi Team,

I've updated the Workbench to 6.3.6. Still not able to connect to fabric.

Thanks,
Naresh
[16 Feb 2016 8:59] Umesh Shastry
Thank you for the feedback.
I'm not seeing the original issue reported, but seeing issue reported by [2 Jun 2015 20:45] Naresh Mote.
[8 Feb 2017 1:25] tsubasa tanaka
There's a statement in Relnote of MySQL Workbench 6.3.9.

> Dropped Fabric support.

https://dev.mysql.com/doc/relnotes/workbench/en/wb-news-6-3-9.html

Should this issue's status be "Won't Fix" or "Unsupported" ?