Bug #74884 Can't open .mwb file
Submitted: 16 Nov 2014 20:59 Modified: 26 May 2015 23:44
Reporter: Bill Plimpton Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S1 (Critical)
Version:6.2.3 OS:Microsoft Windows (Microsoft Windows 7 Professional Service Pack 1)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[16 Nov 2014 20:59] Bill Plimpton
Description:
21:56:46 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Windows version 6.2.3  revision 12312 build 2280 (32 bit)
	Configuration Directory: C:\Users\VladimĂ­r\AppData\Roaming\MySQL\Workbench
	Data Directory: C:\Program Files\MySQL\MySQL Workbench 6.2 CE
	Cairo Version: 1.10.2
	OS: Microsoft Windows 7 Professional Service Pack 1
	CPU: 2x Intel(R) Core(TM)2 Duo CPU     E7400  @ 2.80GHz, 3.0 GiB RAM
	Active video adapter AMD Radeon HD 6700 Series
	Installed video RAM: 512 MB
	Current video mode: 1280 x 1024 x 4294967296 colors
	Used bit depth: 32
	Driver version: 14.301.1001.0
	Installed display drivers: aticfx32.dll,aticfx32.dll,aticfx32.dll,atiumdag.dll,atidxx32.dll,atiumdva.cap
	Current user language: Čeština (Česká republika)

21:56:46 [DB1][            grt]: MySQL Generic Runtime Environment 4.1.0
21:56:46 [DB1][            grt]: 
Type '?' for help.
21:56:46 [DB1][            grt]: Python Shell initialized. (Use Preferences -> General to set language)
21:56:46 [DB1][            grt]: Ready.
21:56:46 [DB1][            grt]: 
21:56:46 [INF][      Workbench]: UI is up
21:56:46 [DB2][WBContext managed]: Activating appview avid2
21:56:46 [DB1][       WBModule]: Reading locally installed MySQL servers
21:56:46 [DB2][       WBModule]: Opening wmi session
21:56:46 [DB1][            wmi]: Creating WmiServices for local server (user: )
21:56:46 [DB1][            wmi]: Allocating wbem locator
21:56:46 [DB2][       WBModule]: Running a wmi query
21:56:47 [DB2][       WBModule]: Closing wmi session
21:56:47 [DB2][       WBModule]: Closing all wmi monitors
21:56:47 [DB1][            wmi]: Destroying services
21:56:47 [DB1][            wmi]: Deallocating wbem locator
21:56:47 [DB1][       WBModule]: Found 0 installed MySQL servers
21:56:47 [DB1][      WBContext]: Saved connection list (MySQL: 0)
21:56:47 [DB1][      WBContext]: Calling SQLIDEUtils.initialize0()...
21:56:47 [DB1][      WBContext]: Calling WbAdmin.initialize()...
21:56:47 [DB1][ mforms managed]: Showing wait message
21:56:47 [ERR][      WBContext]: Cannot open document file: No error
21:56:47 [DB1][ mforms managed]: Showing an error to the user
21:56:47 [DB1][ mforms managed]: Hiding the wait message
21:56:47 [DB2][ mforms managed]: Wait message was visible, finishing it
21:56:47 [DB1][ mforms managed]: About to show a custom message box
21:56:47 [DB1][ mforms managed]: Creating and showing custom message box
21:56:47 [DB1][ mforms managed]: Running custom message box
21:56:49 [DB1][ mforms managed]: Custom message box closed
21:56:49 [DB1][ mforms managed]: Hiding the wait message
21:56:49 [DB2][ mforms managed]: Wait message was not visibile, nothing to do
21:56:49 [INF][      Workbench]: Running the application
21:56:51 [DB1][ mforms managed]: Opening the URL: C:\Users\VladimĂ­r\AppData\Roaming\MySQL\Workbench\log\wb.log

How to repeat:
Try to open this file in MySQL Workbench 6.2.3.12313 CE
https://drive.google.com/file/d/0BzR1yWbK-55_OUdQWW5tQ08tdUk/view?usp=sharing
It show me error: No error.
[16 Nov 2014 21:00] Bill Plimpton
log

Attachment: wb.log (application/octet-stream, text), 17.05 KiB.

[17 Nov 2014 7:21] Umesh Shastry
Hello Bill Plimpton,

Thank you for the report.
Confirmed the issue with WB 6.2.3 on Win7(64 bit).

Thanks,
Umesh
[17 Nov 2014 7:22] Umesh Shastry
Screenshot..

Attachment: 74884.png (image/png, text), 43.79 KiB.

[3 Dec 2014 20:46] Bill Plimpton
Another files, the same problem:
https://drive.google.com/file/d/0BzR1yWbK-55_ekptMVBaWThrWU0/view?usp=sharing
and
https://drive.google.com/file/d/0BzR1yWbK-55_TjBQYVg4emRZTGs/view?usp=sharing

And I have noticed, that if I choose option "Include model..." in a New Model, it show me the same error (like in the screenshot) but after choosing "Close", appear the windows message "The Program MySQL Workbech has stopped working" and there is buttons "Debug", "Close program", but everything close the program and I loose my previous progress.
[13 Apr 2015 21:02] Oracle The Great
Workbench version 6.2.5.0 - it is ok, so it is probably solved, thank you!
[26 May 2015 23:44] Philip Olson
Posted by developer:
 
Fixed as of the MySQL Workbench 6.2.5 release, and here's the changelog entry:

Stability improvements were made to the modeling file save and loading
mechanisms.

Thank you for the bug report.