Bug #74789 Disable formatting on large sql files
Submitted: 11 Nov 2014 10:37 Modified: 15 Apr 2015 11:38
Reporter: Brett Pit Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S5 (Performance)
Version:6.2.3 OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any
Tags: formatting

[11 Nov 2014 10:37] Brett Pit
Description:
Pretty Printing large SQL Scripts (~200M) seems to take a lot of time, so please disable it for large files.

How to repeat:
open a large SQL script and wait...
[11 Nov 2014 12:55] MySQL Verification Team
Please check bug http://bugs.mysql.com/bug.php?id=55312 about loading large files over 100MB. Thanks.
[12 Nov 2014 13:20] Brett Pit
i've cheked: actually the file is loaded and i can execute it then, so no out of memory. Seems to be the same source anyway.

just noticed this answer:

[6 May 2011 7:40] Mike Lischke

The MySQL Workbench SQL Editor is by design not able to load such big scripts. The upper limit is around 100MB, depending on available RAM. A new tool will soon be available to allow executing large scripts (without source
code support, like syntax highlighting, or edit abilities).

... now its 3 years later :D
[12 Nov 2014 15:36] MySQL Verification Team
Thank you for the feedback.
[15 Apr 2015 11:38] Mike Lischke
Since a while there is the "Run SQL script" menu entry in the SQL IDE which can be used to execute a script without loading it into an editor. Additionally, you have the restore functionality in the admin section. In fact such large files are usually db dumps and not meant for visual editing.