Bug #74702 Missing processlist id for sql thread in threads table
Submitted: 5 Nov 2014 19:33 Modified: 11 Jan 10:12
Reporter: Daniël van Eeden (OCA) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Performance Schema Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: Marc Alff CPU Architecture:Any

[5 Nov 2014 19:33] Daniël van Eeden
Description:
The processlist_id in performance_schema.threads for thread/sql/slave_sql is NULL instead of the value shown in the processlist.

How to repeat:
mysql> select * from performance_schema.threads where thread_id=10762\G
*************************** 1. row ***************************
          THREAD_ID: 10762
               NAME: thread/sql/slave_sql
               TYPE: BACKGROUND
     PROCESSLIST_ID: NULL
   PROCESSLIST_USER: root
   PROCESSLIST_HOST: localhost
     PROCESSLIST_DB: NULL
PROCESSLIST_COMMAND: NULL
   PROCESSLIST_TIME: 187883
  PROCESSLIST_STATE: altering table
   PROCESSLIST_INFO: -- xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
ALTER TABLE `xxxxxxxxxxxxxxxxxxxxxxxx`
        ADD COLUMN `xxxxxxxxxxx` DATE NOT NULL DEFAULT '9999-01-01' AFTER `xxxxxxxxxxxxxx`
   PARENT_THREAD_ID: 10741
               ROLE: NULL
       INSTRUMENTED: YES
1 row in set (0.00 sec)

mysql> select * from information_schema.processlist where id=10742\G
*************************** 1. row ***************************
     ID: 10742
   USER: system user
   HOST:
     DB: xxxxxxxxxx
COMMAND: Connect
   TIME: 187886
  STATE: altering table
   INFO: -- xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
ALTER TABLE `xxxxxxxxxx`
        ADD COLUMN `xxxxxxxxxxxxxx` DATE NOT NULL DEFAULT '9999-01-01' AFTER `xxxxxxxxxxxx`
1 row in set (0.03 sec)
[23 Jan 2015 12:55] Mark Leith
Verified as described, thanks for the bug report.
[11 Jan 10:12] Marc Alff
This has been fixed by:

Bug #71682 	PROCESSLIST_ID for slave sql thread is missing

And documented as:

[20 May 2014 0:20] Paul Dubois

Noted in 5.7.5 changelog.

The Performance Schema threads table displayed a PROCESS_ID value of
NULL for replication threads. Now it displays the same ID as SHOW
PROCESSLIST and the INFORMATION_SCHEMA.PROCESSLIST table.

---

Closing as duplicate of Bug#71682