Bug #74611 MySQL-5.6.21-1.el7.x86_64.rpm-bundle.tar doesn't include shared-compat package
Submitted: 29 Oct 2014 5:38 Modified: 30 Oct 2014 17:38
Reporter: tsubasa tanaka (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Packaging Severity:S3 (Non-critical)
Version:5.6.21 OS:Linux
Assigned to: CPU Architecture:Any

[29 Oct 2014 5:38] tsubasa tanaka
Description:
MySQL-5.6.21-1.linux_glibc2.5.x86_64.rpm-bundle.tar, "Linux - Generic (glibc 2.5) (x86, 64-bit), RPM Bundle", doesn't include Compatibility Libraries.

At least, MySQL-5.6.21-1.linux_glibc2.5.i386.rpm-bundle.tar and MySQL-5.6.21-1.el7.x86_64.rpm-bundle.tar are same.

How to repeat:
$ wget http://dev.mysql.com/get/Downloads/MySQL-5.6/MySQL-5.6.21-1.el6.x86_64.rpm-bundle.tar
$ tar tvf MySQL-5.6.21-1.el7.x86_64.rpm-bundle.tar
-rw-r--r-- bteam/staff 19892508 2014-09-12 17:25 MySQL-client-5.6.21-1.el7.x86_64.rpm
-rw-r--r-- bteam/staff 60366256 2014-09-12 17:26 MySQL-server-5.6.21-1.el7.x86_64.rpm
-rw-r--r-- bteam/staff  3522784 2014-09-12 17:25 MySQL-devel-5.6.21-1.el7.x86_64.rpm
-rw-r--r-- bteam/staff 91797228 2014-09-12 17:25 MySQL-embedded-5.6.21-1.el7.x86_64.rpm
-rw-r--r-- bteam/staff  2085708 2014-09-12 17:27 MySQL-shared-5.6.21-1.el7.x86_64.rpm
-rw-r--r-- bteam/staff 58984804 2014-09-12 17:27 MySQL-test-5.6.21-1.el7.x86_64.rpm

Suggested fix:
5.6.20, 5.5.40, 5.7.5-m15's RPM Bundle packages include Compatibility Libraries(shared-compat or libs-compat).

Maybe 5.6.21 have to include it.
[29 Oct 2014 8:35] MySQL Verification Team
Hello tsubasa tanaka,

Thank you for the report.
I confirmed this behavior with MySQL-5.6.21-1.el6.x86_64.rpm-bundle.tar/MySQL-5.6.21-1.el7.x86_64.rpm-bundle.tar, but MyySQL-5.6.20 has this bundled with rest of the rpm's.
 
Not sure whether this is intended behavior because I couldn't find any info to confirm this change.

Thanks,
Umesh
[29 Oct 2014 8:37] MySQL Verification Team
// How to repeat

- Get the rpm-bundle.tar
[root@ushastry Downloads]#  wget http://dev.mysql.com/get/Downloads/MySQL-5.6/MySQL-5.6.21-1.el6.x86_64.rpm-bundle.tar
[root@ushastry Downloads]#  wget http://dev.mysql.com/get/Downloads/MySQL-5.6/MySQL-5.6.21-1.el7.x86_64.rpm-bundle.tar

// Extract and confirm that "shared-compat" is missing

[root@ushastry Downloads]# tar -xvf MySQL-5.6.21-1.el6.x86_64.rpm-bundle.tar
MySQL-test-5.6.21-1.el6.x86_64.rpm
MySQL-shared-5.6.21-1.el6.x86_64.rpm
MySQL-embedded-5.6.21-1.el6.x86_64.rpm
MySQL-devel-5.6.21-1.el6.x86_64.rpm
MySQL-server-5.6.21-1.el6.x86_64.rpm
MySQL-client-5.6.21-1.el6.x86_64.rpm

[root@ushastry Downloads]# tar -xvf MySQL-5.6.21-1.el7.x86_64.rpm-bundle.tar 
MySQL-client-5.6.21-1.el7.x86_64.rpm
MySQL-server-5.6.21-1.el7.x86_64.rpm
MySQL-devel-5.6.21-1.el7.x86_64.rpm
MySQL-embedded-5.6.21-1.el7.x86_64.rpm
MySQL-shared-5.6.21-1.el7.x86_64.rpm
MySQL-test-5.6.21-1.el7.x86_64.rpm

But I see that it is distributed seperately http://dev.mysql.com/downloads/mysql/

Red Hat Enterprise Linux 7 / Oracle Linux 7 (x86, 64-bit), RPM Package Compatibility Libraries		5.6.21	2.2M	Downloadv(MySQL-shared-compat-5.6.21-1.el7.x86_64.rpm)
Red Hat Enterprise Linux 6 / Oracle Linux 6 (x86, 32-bit), RPM Package Compatibility Libraries		5.6.21	3.9M	Download(MySQL-shared-compat-5.6.21-1.el6.i686.rpm)

So, workaround for now is to download it separately.

With 5.6.20, 

[root@ushastry Downloads]#  wget http://dev.mysql.com/get/Downloads/MySQL-5.6/MySQL-5.6.20-1.el7.x86_64.rpm-bundle.tar

[root@ushastry Downloads]# tar -xvf MySQL-5.6.20-1.el7.x86_64.rpm-bundle.tar
MySQL-client-5.6.20-1.el7.x86_64.rpm
MySQL-devel-5.6.20-1.el7.x86_64.rpm
MySQL-embedded-5.6.20-1.el7.x86_64.rpm
MySQL-server-5.6.20-1.el7.x86_64.rpm
MySQL-shared-5.6.20-1.el7.x86_64.rpm
MySQL-shared-compat-5.6.20-1.el7.x86_64.rpm <---------- include din bundled tar
MySQL-test-5.6.20-1.el7.x86_64.rpm
[30 Oct 2014 17:38] Paul DuBois
Noted in 5.6.21 changelog.

RPM Bundle tar file distributions did not include the shared
compatibility library RPM.