Bug #74610 MySQL Installer: Failure to Install MySQL Software
Submitted: 29 Oct 2014 1:17 Modified: 2 Jun 2015 17:11
Reporter: Ernesto Cadorniga Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S1 (Critical)
Version:mysql-installer-community-5.6.21.1 OS:Microsoft Windows ( Windows 7 64 bit)
Assigned to: CPU Architecture:Any
Tags: 64 bit, windows 7

[29 Oct 2014 1:17] Ernesto Cadorniga
Description:
I was trying to install MySQL Server 5.6 for x64 and then the following unhandled exception occurred.

Cannot find a matching quote character for the character "".

Details:

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.FormatException: Cannot find a matching quote character for the character '''.
   at System.DateTimeFormat.ParseQuoteString(String format, Int32 pos, StringBuilder result)
   at System.DateTimeFormat.FormatCustomized(DateTime dateTime, String format, DateTimeFormatInfo dtfi, TimeSpan offset)
   at System.DateTimeFormat.Format(DateTime dateTime, String format, DateTimeFormatInfo dtfi, TimeSpan offset)
   at WexInstaller.Wizards.AddProductsWizard.SelectProductsPage.productTree_AfterSelect(Object sender, TreeViewEventArgs e)
   at System.Windows.Forms.TreeView.TvnSelected(NMTREEVIEW* nmtv)
   at System.Windows.Forms.TreeView.WmNotify(Message& m)
   at System.Windows.Forms.TreeView.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
MySQLInstaller
    Assembly Version: 1.4.2.0
    Win32 Version: 1.4.2.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Installer%20for%20Windows/MySQLInstaller.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
MySQLInstaller.Core
    Assembly Version: 1.4.2.0
    Win32 Version: 1.4.2.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Installer%20for%20Windows/MySQLInstaller.Core.DLL
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
3iffews1
    Assembly Version: 1.4.2.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
rwaryw32
    Assembly Version: 1.4.2.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
3rcshyud
    Assembly Version: 1.4.2.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
2iyhaquy
    Assembly Version: 1.4.2.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Data
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
StandardPlugins
    Assembly Version: 1.4.2.0
    Win32 Version: 1.4.2.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Installer%20for%20Windows/StandardPlugins.DLL
----------------------------------------
System.ServiceProcess
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.ServiceProcess/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.ServiceProcess.dll
----------------------------------------
WindowsBase
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/WindowsBase/v4.0_4.0.0.0__31bf3856ad364e35/WindowsBase.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

How to repeat:
Press "Add" on the dashboard
Explore the MySQL server tree.
Select or Double click the "MySQL Server 5.6.21-X64" or any installable software
[29 Oct 2014 2:39] Ernesto Cadorniga
I'm currently using the following system specifications:

Operating system: Windows 7 professional Service Pack 1
Processor: Pentium(R) Dual-Core CPU E5700 @ 3.00 GHz
Installed RAM: 1.50 GB
System Type: 64-bit Operating System
[29 Oct 2014 22:34] MySQL Verification Team
Thank you for the bug report. Please describe what you did step by step. Thanks.
[31 Oct 2014 4:35] Ernesto Cadorniga
Steps I used to install MySql server
1.Started mysql-installer-community-5.6.21.1 installer
2.Allowed access on UAC
3.Pressed "Add" in the MySql dashboard
4.Searched for MySql server on the selection tree
5.Expand the selection tree until I reach MySql server5.6.21 X64 node
6.Click on the MySql server5.6.21 X64 node

This is when the error occurs:
Cannot find a matching quote character for the character "".
[4 Nov 2014 14:41] MySQL Verification Team
Thank you for the feedback.
[7 Nov 2014 15:46] MySQL Verification Team
http://bugs.mysql.com/bug.php?id=74736 marked as duplicate of this one.
[12 May 2015 23:48] Jose Gabriel Valencia Ornelas
Posted by developer:
 
This bug was in older installers version, please try downlaoding the latest installer and update the catalog
[2 Jun 2015 17:11] Jose Gabriel Valencia Ornelas
This bug was in older installers version, please try downlaoding the latest
installer and update the catalog