Bug #7385 vague error message on retore fail
Submitted: 17 Dec 2004 17:13 Modified: 22 Feb 2006 13:57
Reporter: mike wilson Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Administrator Severity:S3 (Non-critical)
Version:1.0.18 OS:Microsoft Windows (XP Home SP2)
Assigned to: Vladimir Kolesnikov CPU Architecture:Any

[17 Dec 2004 17:13] mike wilson
Description:
I running against MySQL 4.1.8 with Admin 1.0.18.
I useing the same backup file I tried to restore when I logged bug #7208, which was closed/fixed for this release.

I'm trying to restore an backup file from MySQL 4.0.18 using utf8 as the char set encoding.  The real encoding is latin1 but I'm trying to see how well bug #7208 was fixed.

When I click start restore I get this message, which is good to get,

"MySQL Server has returned this Error:
MySQL error Nr. 0-"   

Note the hyphen at the end.

There is no error number 0, I looked in MySQL Server 4.1\Docs\mysqld_error.txt

So what is really the error here?

How to repeat:
retore a backup file that uses latin1 encoding but select utf8 encoding instead.
[5 Jan 2005 11:55] Victoria Reznichenko
Hello, 

I don't get such error if I set latin1 character set instead of utf8.
Could you provide the dump file for testing?
[5 Jan 2005 14:04] mike wilson
File to big to up load
you can download from here
http://www.andargor.com/files/srd35-db-v1.2.zip

file is called srd35-db-v1.2.sql
[5 Jan 2005 18:15] Victoria Reznichenko
I was able reproduce it only if "Target Schema" is "Original Schema". If I specify database name, it works fine.
[25 Feb 2005 14:49] Cory
I'm recieving the same error.  I attempted the posted fix and it didn't work for me.  Anyone have an other suggestions?
[25 Feb 2005 19:11] mike wilson
make sure you have the correct char code selected, prob latin1, and that you have a blank db already created.

mike w.
[27 May 2005 19:10] Vladimir Kolesnikov
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html
[21 Feb 2006 14:52] Joseph Friedman
You might have the name of the database saved with a space. Make sure that you don't have any spaces in the database schema filename
[22 Feb 2006 13:57] mike wilson
nope all one word