Bug #73711 /etc/mysql/debian.cnf not created
Submitted: 25 Aug 2014 15:26 Modified: 11 Sep 2014 6:05
Reporter: Suret Maxime Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:5.6.20 OS:Linux (Debian)
Assigned to: CPU Architecture:Any
Tags: debian-sys-maint, debian.cnf

[25 Aug 2014 15:26] Suret Maxime
Description:
During a fresh install of MySQL 5.6.20, the debian-sys-maint user is created but the file /etc/mysql/debian.cnf is no longer generated, which makes the user unusable.
Note that the file is preserved when upgrading from 5.6.19.

How to repeat:
Make a fresh install of MySQL 5.6.20 on a debian platform from the MySQL APT repository.
[26 Aug 2014 11:21] Umesh Shastry
Hello Omer Dalor,

Thank you for the bug report.

Thanks,
Umesh
[26 Aug 2014 11:25] Umesh Shastry
// debian-sys-maint wasn't created during my tests

root@ushastry:/home/ushastry/Downloads# apt-get install mysql-server 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libdbi-perl libnet-daemon-perl libplrpc-perl libterm-readkey-perl
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  mysql-common mysql-community-client mysql-community-server
The following NEW packages will be installed:
  mysql-common mysql-community-client mysql-community-server mysql-server
0 upgraded, 4 newly installed, 0 to remove and 57 not upgraded.

Need to get 49.9 MB of archives.
After this operation, 162 MB of additional disk space will be used.
0% [Working]to continue [Y/n]? 

Get:1 http://repo.mysql.com/apt/debian/ wheezy/mysql-5.6 mysql-common amd64 5.6.20-1debian7 [731 kB]
Get:2 http://repo.mysql.com/apt/debian/ wheezy/mysql-5.6 mysql-community-server amd64 5.6.20-1debian7 [27.6 MB]
Get:3 http://repo.mysql.com/apt/debian/ wheezy/mysql-5.6 mysql-community-client amd64 5.6.20-1debian7 [21.5 MB]                                                                
Get:4 http://repo.mysql.com/apt/debian/ wheezy/mysql-5.6 mysql-server amd64 5.6.20-1debian7 [10.6 kB]                                                                          
Fetched 49.9 MB in 2min 56s (283 kB/s)                                                                                                                                         
Preconfiguring packages ...
Selecting previously unselected package mysql-common.
(Reading database ... 140271 files and directories currently installed.)
Unpacking mysql-common (from .../mysql-common_5.6.20-1debian7_amd64.deb) ...
Selecting previously unselected package mysql-community-server.
Unpacking mysql-community-server (from .../mysql-community-server_5.6.20-1debian7_amd64.deb) ...
Selecting previously unselected package mysql-community-client.
Unpacking mysql-community-client (from .../mysql-community-client_5.6.20-1debian7_amd64.deb) ...
Selecting previously unselected package mysql-server.
Unpacking mysql-server (from .../mysql-server_5.6.20-1debian7_amd64.deb) ...
Processing triggers for man-db ...
Setting up mysql-common (5.6.20-1debian7) ...
Setting up mysql-community-server (5.6.20-1debian7) ...
......
[info] MySQL Community Server 5.6.20 is started.
Setting up mysql-community-client (5.6.20-1debian7) ...
Setting up mysql-server (5.6.20-1debian7) ...

root@ushastry:/home/ushastry/Downloads# ls -l /etc/mysql/
total 8
drwxr-xr-x 2 root root 4096 Jul 29 07:03 conf.d
-rw-r--r-- 1 root root 1820 Jul 29 07:03 my.cnf

root@ushastry:/home/ushastry/Downloads# more /etc/apt/sources.list.d/mysql.list 
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://repo.mysql.com/apt/debian/ wheezy mysql-5.6
deb-src http://repo.mysql.com/apt/debian/ wheezy mysql-5.6
[5 Sep 2014 11:33] Akhil Mohan
Hi Omer,

Nice to know your feedback on our APT repo packages. Unfortunately, you have been hit by an unsupported case where we do not provide both debian-sys-maint user debian.cnf file through our packages. They are provided only by the native repo packages.

I think 5.6.19->5.6.20 upgrade you did was from native packages to our packages and thus the account and file were kept intact for you to avoid trouble. When you performed a fresh installation our packages did not create either of them.

You noticed the user account possibly due to reuse of same data dir that was created by the native repo packages (5.6.19). While you attempted a purge on native packages, the files under /etc/mysql were removed as expected and were not to be found after you did fresh install of 5.6.20.

In case, you are planning to get the latest version from us then you need not purge or remove the existing native repo package. Our packages will seamlessly upgrade and also keep the config file and user intact for you. You may have already experienced the same while upgrading from 5.6.19 to 5.6.20.

I would also advice not to purge any of the mysql packages as it may result in data loss. Let me know if you still have any doubts.

Regards,
Akhil