Bug #73670 mysq_config_editor not present in the community packages for debian wheezy
Submitted: 21 Aug 2014 13:17 Modified: 29 May 2017 6:52
Reporter: giuseppe urso Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Packaging Severity:S3 (Non-critical)
Version:>=5.6.19 OS:Linux (Debian 7 (Wheezy))
Assigned to: CPU Architecture:Any

[21 Aug 2014 13:17] giuseppe urso
Description:
Hi, I can't find the mysql_config_editor binary in any of the debian wheezy related packages.

How to repeat:
Download and install packages present in mysql-server_5.6.20-1debian7_amd64.deb-bundle.tar

Suggested fix:
Add the binary to the .deb package
[21 Aug 2014 13:56] giuseppe urso
Fixed typo and made more precise about which package (removed the word "server")
[21 Aug 2014 14:42] Miguel Solorzano
Thank you for the bug report.
[1 Sep 2014 11:39] Akhil Mohan
Hi Giuseppe,

We appreciate your feedback on the said mysql_config_editor utility. This utility relates to configuration editing mostly used for development. All such development related utilities, header files etc find place in the libmysqlclient-dev package that is not part of the bundle tar.

In case you wish to use this functionality then please download the said package separately from dev.mysql.com and install on your system. Once installed, the utility will be available on that system.

We will try to see how can this information be reflected in docs to avoid the situation for other users. Thanks for your feedback.

Please let me know if you face any difficulty in handling the installation of the individual package.

Regards,
Akhil
[8 Oct 2014 17:30] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=74281 marked as duplicate of this one.
[31 Oct 2014 13:09] Przemyslaw Malkowski
So the mysq_config_editor is supposed to not be present in the client package on Ubuntu, so why it is present in Fedora one? I can see some inconsistency here.
Also this tool seems to be the only way to allow paswordless access with the password stored in hashed file (.mylogin.cnf)?

root@ubuntu-14:~# apt-cache show mysql-community-client
Package: mysql-community-client
Source: mysql-community
Version: 5.6.21-1ubuntu14.04
Architecture: amd64
(...)

root@ubuntu-14:~# dpkg -L mysql-community-client
/.
/usr
/usr/bin
/usr/bin/mysql_plugin
/usr/bin/mysqladmin
/usr/bin/mysqlslap
/usr/bin/mysqlaccess.conf
/usr/bin/innochecksum
/usr/bin/mysql_waitpid
/usr/bin/mysql_client_test_embedded
/usr/bin/mysql_find_rows
/usr/bin/mysqlcheck
/usr/bin/myisam_ftdump
/usr/bin/mysql_client_test
/usr/bin/mysqldump
/usr/bin/mysqlaccess
/usr/bin/mysql
/usr/bin/mysql_fix_extensions
/usr/bin/mysql_embedded
/usr/bin/mysqldumpslow
/usr/bin/mysqlimport
/usr/bin/mysqlshow
/usr/bin/mysqlbug
/usr/share
/usr/share/man
(...)

[root@pmlap ~]# rpm -ql mysql-community-client-5.6.21-1.fc20.x86_64
/usr/bin/msql2mysql
/usr/bin/mysql
/usr/bin/mysql_config
/usr/bin/mysql_config-64
/usr/bin/mysql_config_editor
/usr/bin/mysql_find_rows
/usr/bin/mysql_waitpid
/usr/bin/mysqlaccess
/usr/bin/mysqlaccess.conf
/usr/bin/mysqladmin
/usr/bin/mysqlbinlog
/usr/bin/mysqlcheck
/usr/bin/mysqldump
/usr/bin/mysqlimport
/usr/bin/mysqlshow
/usr/bin/mysqlslap
/usr/share/man/man1/msql2mysql.1.gz
(...)
[2 Oct 2015 18:49] James Day
I've changed this from not a bug severity 3 to verified severity 2 because mysql_config_editor is a user-level tool that we want as many end users as possible to use. It is not a developer-only tool and needs to be part of all of our distributions intended for those who will use the client program mysql. If mysql client is present in a distribution, mysql_config_editor needs to be as well because they are part of a set of related components.

For background see items such as this blog entry by Todd Farmer:

http://mysqlblog.fivefarmers.com/2012/08/16/understanding-mysql_config_editors-security-as...

James Day, MySQL Senior Principal Support Engineer, Oracle
[2 Oct 2015 18:50] James Day
Actually left this as S3 rather than S2, though it needs to be fixed in the next build for affected products if possible.
[7 Dec 2015 23:35] Warren Prince
I'm having problems using this with the broadly used mysql2 gem for Ruby on Rails.  I do have libmysqlclient_dev installed and am using MySql 5.6.27.  Whenever that gem attempts to make a connection, I get a segmentation fault:

error: Found option without preceding group in config file: /home/user/.mylogin.cnf at line: 2
Fatal error in defaults handling. Program aborted
/home/user/.rvm/gems/ruby-2.1.2/gems/mysql2-0.3.18/lib/mysql2/client.rb:70: [BUG] Segmentation fault at 0x00000500000000
ruby 2.1.2p95 (2014-05-08 revision 45877) [x86_64-linux]

The folks at MySql2 are wondering if the file name and login-path need to be presented to you in some special way?   Apparently it works well with an unencrypted my.cnf containing the login creds.

Is this still being worked on?
[29 May 2017 6:52] Lars Tangvald
Posted by developer:
 
This bug had a bad category set, so was forgotten. But as of 5.6.36, the mysql_config_editor binary is present in mysql-community-client (not sure exactly when the problem was fixed).