Bug #73487 closed query tabs reopening after restarting on mac
Submitted: 6 Aug 2014 13:57 Modified: 21 Aug 2014 21:32
Reporter: austin woz Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.1.7 OS:Mac OS X (10.9.4)
Assigned to: CPU Architecture:Any
Tags: opening, tabs

[6 Aug 2014 13:57] austin woz
Description:
Hi, I am having an issue with query tabs when i start workbench. it does not remember the state of the query tabs as it was when closing. Specifically I close all tabs, then open workbench again and the tabs are open again as if i never closed them.

I am using latest workbench on Mac OSX. I had same issue with previous workbench version

This bug might be similar to #73472

Thanks for a great product. 
PS any chance of a visual query builder like seen in SQLyog or MS access.

How to repeat:
to repeat:

1. open multiple query tabs, and execute statements in each tab. Keep tabs open for a period of time.
2. Close each and all of the query tabs
3. Exit from Mysql workbench
4. At a later date, open workbench and the query tabs are reopened as if i never closed them in step 2.

Problem is, if i repeat the steps above I do not have the issue. But when using it daily i always have this issue. I therefore must assume in step 1 the tabs need to be open for a period of time, maybe for an autosave to kick in, or something to do with multiple statements, i don't know. It is annoying me enough that I wanted to post it and hope it gets fixed or a solution given. 

(It might be the case, that when i close the tabs it does not ask if they should be saved or not, yet when i do the above steps it does ask if they should be saved)

Suggested fix:
I think this is related to some background autosave
[6 Aug 2014 18:26] MySQL Verification Team
Thank you for the bug report. Verified as described.
[20 Aug 2014 21:56] Johannes Taxacher
Posted by developer:
 
fix confirmed in 6.2.1
[21 Aug 2014 21:32] Philip Olson
Fixed as of the MySQL Workbench 6.2.0 release, and here's the changelog entry:

On Mac OS X, closed query tabs could reopen after restarting MySQL Workbench.

Thank you for the bug report.
[11 Sep 2014 22:50] MySQL Verification Team
http://bugs.mysql.com/bug.php?id=73898 marked as duplicate of this one.
[22 Sep 2014 8:41] Dominik Gajewski
the same issue I can noticed on Ubuntu 12.04 LTS and 14.04 LTS
[26 Nov 2015 14:13] paulo medeiros
Why is closed?
This still happens on version 6.3.3 and Windows 7.
[23 Dec 2015 14:17] Andres Giordano
This is not a bug!!! You have to go to Edit --> Preferences --> General --> SQL Editor (panel) and uncheck "Save snapshot of open editor...."

bie