Bug #73373 Warning message shows old variable name
Submitted: 24 Jul 2014 10:57 Modified: 4 Nov 2014 15:24
Reporter: tsubasa tanaka (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Errors Severity:S3 (Non-critical)
Version:5.6.19 OS:Any
Assigned to: CPU Architecture:Any
Tags: Changed limits, table_cache, table_open_cache, warning

[24 Jul 2014 10:57] tsubasa tanaka
Description:
Following warning message shows old variable name "table_cache", that variable is called "table_open_cache" currently (After MySQL 5.1.3).

2014-07-24 19:56:29 9358 [Warning] Buffered warning: Changed limits: table_cache: 4015 (requested 100000)

How to repeat:
$ bin/mysqld --no-defaults --table-open-cache=100000

Suggested fix:
*** sql/mysqld.cc.orig  2014-05-06 19:45:59.000000000 +0900
--- sql/mysqld.cc       2014-07-24 19:45:22.969471661 +0900
***************
*** 6931,6937 ****
      char msg[1024];

      snprintf(msg, sizeof(msg),
!              "Changed limits: table_cache: %lu (requested %lu)",
               limit, table_cache_size);
      buffered_logs.buffer(WARNING_LEVEL, msg);

--- 6931,6937 ----
      char msg[1024];

      snprintf(msg, sizeof(msg),
!              "Changed limits: table_cache_size: %lu (requested %lu)",
               limit, table_cache_size);
      buffered_logs.buffer(WARNING_LEVEL, msg);
[24 Jul 2014 13:48] Miguel Solorzano
Thank you for the bug report.
[4 Nov 2014 15:24] Paul Dubois
Noted in 5.7.6 changelog.

Some server warning messages referred to the table_open_cache system
variable using its old name of table_cache.
[3 Dec 2014 11:00] Umesh Shastry
Bug #75081 marked as duplicate of this