Bug #73343 Workbench Freezes on Remote SSH Server Query
Submitted: 21 Jul 2014 14:27 Modified: 5 Jan 2016 6:56
Reporter: Conor O'Toole Email Updates:
Status: Duplicate Impact on me:
Category:MySQL Workbench Severity:S2 (Serious)
Version:, 6.3.6 OS:Windows (Windows 7, connecting to UBUNTU webservice)
Assigned to: CPU Architecture:Any
Tags: Error Code 2013

[21 Jul 2014 14:27] Conor O'Toole
Workbench freezes after I run an SQL wuery and eventually times out with the error:
Error Code: 2013. Lost connection to MySQL server during query

I recently upgraded my local PC from vista to Windows 7 where I run workbench to connect to a remote Ubuntu server on Amazon AWS (EC2 server, RDS database). This error has only happened since I downloaded the new version of workbench on my Local windows 7 machine. No settings (e.g. packet size settings) have been changed on the server where workbench used to connect without issue.

How to repeat:
When I try to run a large query (limited to 1000 rows) such as:

Workbench will freeze and try to run the script for ~5 min. If I try to perform any other action e.g. Stop the query - Workbench stops responding entirely

If I run a smaller query however it works:
Select * from users WHERE id=1

Suggested fix:
Is this an isolated incident? Is there a compatibility issue with Amazon and recent updates of Workbench?
[21 Jul 2014 15:00] Peter Laursen
(again) this could because the query results in a larger packet (string) than max_allowed-packet setting on the server allows for. In such cases the server will simply disconnect the client.

-- Peter
-- not a MySQL/Oracle person
[21 Jul 2014 15:30] Peter Laursen
.. and besides there is no *crash* at all here.
[21 Jul 2014 16:16] Conor O'Toole
To confirm, this is not a max_packet issue.

I can also confirm that I have downloaded the old workbench version 6.0.9 and everything works correctly using settings saved from version 6.1.7. So this is indeed an issue with the new release.
[21 Jul 2014 16:18] Conor O'Toole
Changed "Crashes" to "Freezes" in title. Title elaborated on.
[18 Aug 2014 13:40] MySQL Verification Team
http://bugs.mysql.com/bug.php?id=73511 marked as duplicate of this one.
[8 Sep 2014 11:58] MySQL Verification Team
Please try Development Releases 6.2.2 rc version. Thanks.
[9 Oct 2014 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[20 Dec 2014 22:34] Azim Sonawalla
Update on this: coming across the same error in 6.2 on Win7 connected to AWS.  Problems exactly as described.

Interestingly enough, I have another local machine running 6.1 on Mac OSX that runs without problems.

Downgrading my Win7 machine to 6.1 has not solved the issue.
[20 Dec 2014 22:54] Azim Sonawalla
Another update: the freezing seems to only be a problem when connected over SSH.  Just tested on 6.1 and 6.2 on Win7 without using an SSH connection and the problem is no longer present.
[17 Jan 2015 13:04] Erwin de Haan
This bug it still there is (64 bit) Win 8.1 This time to a Ubuntu Azure Server over SSH.
[17 Jan 2015 13:16] Erwin de Haan
I added a log file. I had to force quit workbench at the end of the thing. It might be an idea to have a cancel query button somehwere.
[3 Feb 2015 14:21] Graham Laughton
I have the same problem. I can connect to a local database and run queries with no problem, but as soon as I use a WB SSH connection with e.g. a "SELECT * FROM ..." query it hangs. If I try to close WB I get 'MySQL Workbench is not responding". SELECT id FROM ..." works OK.

Same problem if I select "Server Status" from the MANAGEMENT options.

I am running WB version Build 2280 32 bits on Windows 7.
[17 Feb 2015 21:46] mark bucknell
I also experience this same problem. 
I am connecting to my vagrant over SSH and I find when I run this query for the first time it works: "SELECT * FROM products.apparel where group_id is null" - Duration: 467 row(s) returned	0.016 sec / 0.016 sec ... however trying to run it immediately again sees the  query just display the "Running" message. This never goes away. I have to click stop query so the software stops responding the close the software from task manager.

Could this have something to do with some sort of caching? I updated my max_allowed_packet = 500mb

.. New revelation.. as I was writing this post I was still testing and that same query shows "Running" from 08:31:26 til 08:43 then finished with results. But the duration shows:	467 row(s) returned	0.000 sec / 0.094 sec

Why did it take 12 min to display that when it says it finished it in less than a second?
[17 Feb 2015 22:26] mark bucknell
After it runs for ages and finally stops I get Error Code: 2013 Lost connection to MySQL server at 'waiting for initial communication packet', system error: 10060
[22 Apr 2015 8:38] Simon Berger
I would call this a duplicate to http://bugs.mysql.com/bug.php?id=74557
There are too many old bugs open to the same issue.
[5 Jan 2016 6:56] MySQL Verification Team
Marking this as duplicate of Bug #79840