Bug #73323 MySQL Community edition is not offered anymore for blind programmers.
Submitted: 18 Jul 2014 9:39 Modified: 21 Jul 2014 19:01
Reporter: Gigi Becali Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Installing Severity:S1 (Critical)
Version: OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: accessibility, Captcha, MySQL, windows

[18 Jul 2014 9:39] Gigi Becali
Description:
In order to download MySQL Community Edition the Oracle web site requires the user to complete a form which is not accessible for the blind because it uses a Captcha that doesn't offer an audio alternative.
Without completing that form, MySQL can't be downloaded by the blind programmers.

Please offer an accessible alternative.

How to repeat:
Searched "download mysql windows" with Google, clicked on the first found page, tried to download MySQL 5.6 for Windows.

Suggested fix:
The best fix would be to create a text-captcha that blocks only the universal robots in case this is what you need. In case that you observed that targetted robots have been made to download MySQL automaticly, use an image-based Captcha, but one that also offer an accessible audio alternative for the blind, like Google reCaptcha.
[21 Jul 2014 11:25] Sveta Smirnova
Thank you for the report.

You don't have to fill up the form, just use link "No thanks, just start my download."

Regarding to the form and the captcha this is not MySQL who maintain it, this is global Oracle thing.
[21 Jul 2014 16:27] Gigi Becali
[21 Jul 11:25] Sveta Smirnova
Thank you for the report.
You don't have to fill up the form, just use link "No thanks, just
start my download."

I tried again and I reached again at the form in the page:

http://dev.mysql.com/downloads/file.php?id=452188

There is no "No thanks, just start my download" button on that page.

I reached on that page from the page:

http://dev.mysql.com/downloads/mysql/

Where I clicked on the link for downloading:

Windows (x86, 32-bit), ZIP Archive  5.6.19  

But same form with Captcha is offered when trying to download the recommended file.

I have used this way of contacting Oracle because there is no other way accessible for the blind. On every other place where the developers can contact Oracle there are forms with Captcha which don't offer an audio alternative.

Thanks.
[21 Jul 2014 17:09] Sveta Smirnova
Gigi,

thank you for the feedback.

You are correct, there is no button with name "No thanks, just start my download.", but there is a link with the same text. Particularly on the page link to which you provided it refers URL http://dev.mysql.com/get/Downloads/MySQL-5.6/mysql-5.6.19-win32.zip

Regarding to captcha I agree this is unacceptable that it does not work for blind people independently if this is required to download MySQL server or not and I will try to raise this concern internally. But this is really not MySQL department who is responsible for this.
[21 Jul 2014 19:01] Gigi Becali
Thank you! Now I found that the link with "no thanks and start downloading" appears only in the page where is needed to click on the login link. I have seen that link, and because I have an Oracle account I logged in without reading the rest of the page. After logging in, in the page with the form that link doesn't appear. Thank you for the direct link also.