Bug #73253 "Unexpected Error" message while adding new rows with "form editor"
Submitted: 10 Jul 2014 8:33 Modified: 13 Nov 2014 1:39
Reporter: Karo S Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:6.1.7.11891 bulid 1788 OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any
Tags: Form Editor

[10 Jul 2014 8:33] Karo S
Description:
Problem when updating an existing database using "form editor" and then the button "Add a new row to the recordset".

Adding more than one row using the button results in the message: "Unexpected error. MySQL Workbench has encountered a problem. Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index".

How to repeat:
Adding just one row and hitting "Apply" works just fine.

The error message appears only when I add one row, don't hit "Apply", and try to add another row using the button.
[10 Jul 2014 9:22] MySQL Verification Team
Hello Karo,

Thank you for the bug report.
Verified as described on Win7 with WB 6.1.7.

Thanks,
Umesh
[10 Jul 2014 9:24] MySQL Verification Team
Screenshot..

Attachment: 73253.png (image/png, text), 52.03 KiB.

[27 Aug 2014 9:12] Mike Lischke
Can you please test this with WB 6.2? It appears this problem has been fixed already, but I'd like to have a confirmation.
[28 Sep 2014 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[8 Oct 2014 9:47] Mike Lischke
Posted by developer:
 
This has been fixed already. No feedback from the user to test it with the latest version of WB.
[16 Oct 2014 10:19] Karo S
The bug is still there in 3.2.3.
[16 Oct 2014 10:24] Mike Lischke
Well, the current version is 6.2.3.

So you see exactly the same issue? You ran your query, switched to the form editor, clicked "Add Row" and then again "Add Row" and that exception came up? I cannot reproduce this here and also QA didn't find any problem.
[16 Oct 2014 10:32] Karo S
You're right, it's 6.2.3, my mistake...

Yes, I run a query -> "form" editor ->  fill out the new record -> (don't hit "apply") -> hit "add row" -> the error message appears (the workbench doesn't acctually crash)

Is there a way for me to give you more information? I don't know, some screenshots maybe?
[16 Oct 2014 10:35] Mike Lischke
A screenshot is a good idea. I need something to reproduce that crash, otherwise I cannot fix it.
[16 Oct 2014 10:35] Karo S
The key issue seems to be filling out the first new record before hitting "add row".
[16 Oct 2014 10:41] Mike Lischke
Is it an empty table or does it contain something already?
[16 Oct 2014 10:43] Karo S
It contains data and I just add new records to it.
[13 Nov 2014 1:39] Philip Olson
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 6.2.4 release, and here's the changelog entry:

Attempting to add multiple entries using the results view "Form Editor"
would fail and generate an exception unless "Apply" was clicked after each
individual entry.

Thank you for the bug report.