Bug #7321 Crashes when using identifier quote - character backtick
Submitted: 15 Dec 2004 15:53 Modified: 16 May 2005 16:01
Reporter: Phillip Hamilton-Wilks Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Query Browser Severity:S1 (Critical)
Version:1.1.3a OS:Linux (Linux Fedora Core 3)
Assigned to: Vladimir Kolesnikov CPU Architecture:Any

[15 Dec 2004 15:53] Phillip Hamilton-Wilks
Description:
Mysql Query Browser crashes when using the identifier quote - character backtick (``'):
I know using spaces is silly but my clients give me tables to convert from Access. They usually
contain spaces and then plan to use Openoffice as an ODBC frontend to MySQL.
For the initial anaylsis they do not want the field names changed.

select `A01 Name` from users limit 10;

How to repeat:
select `A01 Name` from users limit 10; or something similar depending on whether you have a field with spaces
[4 Jan 2005 16:57] Victoria Reznichenko
MySQL Query Browser doesn't crash for me, but produces an error:
"Unknown column 'xxxxx' in 'field list'"
[11 Apr 2005 9:45] Alfredo Kojima
Can you please confirm whether the bug persists in the latest release? I could not reproduce it in 1.1.3a neither in 1.1.6
[16 May 2005 16:01] Vladimir Kolesnikov
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html