Bug #73090 Can't move EER Diagram tables
Submitted: 24 Jun 2014 8:06 Modified: 29 Aug 2014 1:19
Reporter: Scott Berry Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S5 (Performance)
Version:6.1.6 OS:Microsoft Windows (Microsoft Windows 7 Service Pack 1 build 7601, 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[24 Jun 2014 8:06] Scott Berry
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\seberry\AppData\Roaming\MySQL\Workbench/log/wb.log]

How to repeat:
The first time any EER Diagram is opened, table can be click-and-dragged about, but when ANY EER Diagram tabs get closed, they all prevent any further click and drag operations on even newly opened EER Diagram tabs. Only remedy seems to be to close Workbench and re open.

If a second EER Diagram tab is opened before the bug has prevented click and drags, then Workspace throws the error:
Index was out of range. Must be a non-negative and less than the size of the collection.
Parameter name: index
[24 Jun 2014 11:44] Miguel Solorzano
Thank you for the bug report. Are you able to provide the model project file (private if you wish)?. Thanks.
[24 Jun 2014 23:59] Scott Berry
I created a new Model, created an EER Diagram with 2 empty tables. Closing and reopening this diagram will prevent the tables from being moved. I doubt it is a file problem, especially seeing that I can replicate this in a new model that hasn't been saved yet.
[25 Jun 2014 0:11] Miguel Solorzano
Thank you for the feedback. I was able to repeat.
[26 Aug 2014 21:04] Juan Rene Ramirez Monarrez
Posted by developer:
 
There was some old hack causing the logic to work as expected, after removing it the error was not reproducible.

Thanks for submitting this bug, solution will be available on 6.2
[29 Aug 2014 1:19] Philip Olson
Fixed as of the upcoming MySQL Workbench 6.2.2 release, and here's the changelog entry:

Tables could not be clicked-and-dragged after closing any other EER
diagram tab.

Thank you for the bug report.