Bug #73069 MySQL Connector/Python MSI Installer Does Nothing
Submitted: 20 Jun 2014 18:57 Modified: 3 Jan 21:04
Reporter: Grant Posner Email Updates:
Status: Unsupported Impact on me:
Category:Connector / Python Severity:S2 (Serious)
Version: OS:Windows
Assigned to: CPU Architecture:Any
Tags: connector, installer, msi, python

[20 Jun 2014 18:57] Grant Posner
I have several versions of Python installed: 3.2, 3.3, and 3.4. I need to install the MYSQL connector for Python on Windows 8, but when I run any of the MSI installers from http://dev.mysql.com/downloads/connector/python/ the installer begins, says that it is "gathering required information", and then closes a split second later.
The progress bar moves forward a bit (less than 10%) initially, but then goes back to 0% as the installer closes; this makes me think that the installer is encountering an error and is rolling back anything it does, but without notifying me by using error dialogs or the like.

How to repeat:
Run any of the MSI installers from http://dev.mysql.com/downloads/connector/python/ on a Windows 8 computer.
[23 Jun 2014 8:34] Geert Vanderkelen
The MSI need to be reworked, especially when Python is not installed in the default location (C:\PythonXY). Is this the case on your machine?

This is not the best solution, but installing using the Generic Distribution and , using cmd or PowerShell, executing setup.py install should work for which every version you have installed. Also using pip. It might be a bit more Pythonic this way.

Note that the MSI for download are for 2.7, 3.2 and 3.3 only right now.
[23 Jun 2014 15:14] Grant Posner
I do have Python 3.3.5 installed at C:\Python33, but when I run the mysql-connector-python-1.2.2-py3.3.msi installer, it still gives up while "gathering required information".
[2 Nov 2015 11:18] Бекзат Шаяхметов
Could you tell me please if you have solved your problem? I have the same problem with the mysql connector (Python 3.4)
[20 May 2022 8:08] Nuno Mariz
Thank you for the bug report.

The MSI package has been reworked. It's expected that everything works now.
Please let us know if the issue persists.
[3 Jan 21:04] Oscar Pacheco
Thank you for taking the time to report a problem.  Unfortunately you are not using a current version of the product you reported a problem with -- the problem might already be fixed. Please download a new version from http://www.mysql.com/downloads/

If you are able to reproduce the bug with one of the latest versions, please change the version on this bug report to the version you tested and change the status back to "Open".  Again, thank you for your continued support of MySQL.