Bug #73052 Sporadical failure in the tc_log_mmap unit test.
Submitted: 19 Jun 2014 13:12 Modified: 4 Jul 2014 11:09
Reporter: Dmitry Shulga Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: XA transactions Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: CPU Architecture:Any

[19 Jun 2014 13:12] Dmitry Shulga
Description:
The tc_log_mmap unit test started failing after the patch for
Bug#18913949: USE REASONABLE DEFAULTS WHEN INITIALIZING THD/TRANS MEM_ROOTS
has been applied. This patch changed the defaults for the Transaction_ctx
(and THD) MEM_ROOTs.

The problem seems to be that we construct several instances of
TC_Log_MMap_thread that run concurrently and that these use the same
instance of TCLogMMapTest. This means that they also use the same THD,
same Transaction_ctx and the same Transaction_ctx::m_mem_root.

How to repeat:
Build and run the tc_log_mmap unit test several times.
[19 Jun 2014 13:16] Dmitry Shulga
To reproduce the bug please revert the changes introduced by a post-push fix for Bug#18913949
(changeset with revno:8217).
[4 Jul 2014 11:09] Paul Dubois
Fixed in 5.7.5.

Bug affects no released version. No changelog entry needed.