Bug #72967 Workbench 6.1.6 displays only portions of results columns
Submitted: 11 Jun 2014 23:58 Modified: 28 Aug 2014 0:41
Reporter: George Marshall Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:6.1.6.11834 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: display size, editor, rsult columns

[11 Jun 2014 23:58] George Marshall
Description:
The Workbench editor, 6.1.6, now by default shows only a portion of results column data.  The number of data characters is somewhat dependent on the width of the column label in the results panel.
The problem is that for any query, it is necessary to manually widen all columns so the results data can be seen.

In 6.0.9 and prior versions, all characters in data columns were shown, up to the right edge of the results panel size.

I was unable to find a Preferences setting to correct this problem.

How to repeat:
This query shows the same 10-character constant in different columns that have different widths of column labels.:

select '123456789_' as B,  '123456789_' as Babc, '123456789_' as Babcde, '123456789_' as Babcdef

The results of the query show, by default:
B      Babc     Babcde     Babcdef
123... 12345... 1234567... 123456789_

Note that the correct data can be seen by manually widening each column in th results panel, a needless use of developer time.

Suggested fix:
Return to the prior behavior of showing all characters in each column.
If this was a deliberate I change, I down-vote it, and would ask, at minimum, for a Preferences setting to show all characters.
[12 Jun 2014 12:32] Umesh Shastry
Hello George,

Thanks you for the bug report.
Verified as described.

Thanks,
Umesh
[12 Jun 2014 12:33] Umesh Shastry
This seems to be repeatable with only Windows environment.

How to repeat:

Just try to execute below query:

select '123456789_' as B,  '123456789_' as Babc, '123456789_' as Babcde, '123456789_' as Babcdef
[12 Jun 2014 12:54] Umesh Shastry
Ubuntu 14.0.4 Screenshot - Not affected

Attachment: Screenshot from 2014-06-12 17:55:54.png (image/png, text), 212.76 KiB.

[12 Jun 2014 12:58] Umesh Shastry
Windows screenshot - Affected

Attachment: 72967.png (image/png, text), 152.02 KiB.

[28 Aug 2014 0:41] Philip Olson
Fixed as of the upcoming MySQL Workbench 6.2.2 release, and here's the changelog entry:

The results grid columns only showed a small number of characters.

Thank you for the bug report.