Bug #72841 Bulk Data Tranfer Failed: Error getting row count from source tables
Submitted: 2 Jun 2014 21:16 Modified: 12 Sep 2014 17:05
Reporter: Zac Lippard Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Workbench: Migration Severity:S2 (Serious)
Version:6.1.6 OS:Microsoft Windows (Windows 7)
Assigned to: CPU Architecture:Any
Tags: migration, MSSQL, MySQL

[2 Jun 2014 21:16] Zac Lippard
Description:
I am trying to migrate a database from Microsoft SQL Server to MySQL and am running in to the following the error at the Bulk Data Transfer Stage.  The first time I ran this it worked perfectly with no issues, but I when I went to run this again, using the same credentials and source & target databases it's been failing.  Here's the ouput:

Starting...
Prepare information for data copy...
Prepare information for data copy done
Determine number of rows to copy....
Counting number of rows in tables...
wbcopytables.exe --count-only --passwords-from-stdin --odbc-source="DRIVER={SQL Server};SERVER=sql1;DATABASE={};UID=sa" --table-file=c:\users\zlippard\appdata\local\temp\tmpmdvgxh
The system cannot find the path specified.
14:06:36 [INF][      copytable]: --table [NBI]	[dbo].[BUSINESS]
14:06:36 [INF][      copytable]: --table [NBI]	[dbo].[OWNER]
14:06:36 [INF][      copytable]: Opening ODBC connection to 'DRIVER={SQL Server};SERVER=sql1;DATABASE={};UID=sa;PWD=XXX'
14:06:36 [INF][      copytable]: ODBC connection to 'DRIVER={SQL Server};SERVER=sql1;DATABASE={};UID=sa;PWD=' opened

ERROR: Determine number of rows to copy: Error getting row count from source tables
Failed

Here's the console output from the Output window:

Traceback (most recent call last):
  File "C:\Program Files (x86)\MySQL\MySQL Workbench 6.1 CE\workbench\wizard_progress_page_widget.py", line 192, in thread_work
    self.func()
  File "C:\Program Files (x86)\MySQL\MySQL Workbench 6.1 CE\modules\migration_data_transfer.py", line 553, in _count_rows
    total = self._transferer.count_table_rows(self._working_set)
  File "C:\Program Files (x86)\MySQL\MySQL Workbench 6.1 CE\modules\DataMigrator.py", line 253, in count_table_rows
    raise Exception("Error getting row count from source tables")
Exception: Error getting row count from source tables

How to repeat:
Selected a source ODBC connection for SQL Server and target MySQL database.  Used default 'sa' user for SQL Server and 'root' user for MySQL.  Worked fine the first time, but has been failing ever since.
[12 Aug 2014 17:05] Miguel Solorzano
Please try version 6.1.7 and Connection Method ODBC (native) for SQL Server. Thanks.
[13 Sep 2014 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".